]> git.draconx.ca Git - gentoo-fixes.git/blob - x11-base/xorg-x11/xorg-x11-7.4-r2.ebuild
Initial commit
[gentoo-fixes.git] / x11-base / xorg-x11 / xorg-x11-7.4-r2.ebuild
1 # Copyright © 2014,2017 Nick Bowler
2 # License GPLv2+: GNU General Public License version 2 or later.
3 # There is NO WARRANTY, to the extent permitted by law.
4 #
5 # This a modified version of the original ebuild from Gentoo GNU/Linux,
6 # covered by the following copyright and permission notice:
7 #
8 #   Copyright 1999-2017 Gentoo Foundation
9 #   Distributed under the terms of the GNU General Public License v2
10
11 EAPI="2"
12
13 inherit eutils
14
15 DESCRIPTION="An X11 implementation maintained by the X.Org Foundation (meta package)"
16 HOMEPAGE="https://www.x.org/wiki/"
17
18 LICENSE="metapackage"
19 SLOT="0"
20 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
21 IUSE="bh-fonts"
22
23 # Server
24 RDEPEND="${RDEPEND}
25         x11-base/xorg-server[-minimal]"
26
27 # Applications
28 RDEPEND="${RDEPEND}
29         x11-apps/appres
30         x11-apps/bitmap
31         x11-apps/iceauth
32         x11-apps/luit
33         x11-apps/mkfontdir
34         x11-apps/mkfontscale
35         x11-apps/sessreg
36         x11-apps/setxkbmap
37         x11-apps/smproxy
38         x11-apps/x11perf
39         x11-apps/xauth
40         x11-apps/xbacklight
41         x11-apps/xcmsdb
42         x11-apps/xcursorgen
43         x11-apps/xdpyinfo
44         x11-apps/xdriinfo
45         x11-apps/xev
46         x11-apps/xf86dga
47         x11-apps/xgamma
48         x11-apps/xhost
49         x11-apps/xinput
50         x11-apps/xkbcomp
51         x11-apps/xkbevd
52         x11-apps/xkbutils
53         x11-apps/xkill
54         x11-apps/xlsatoms
55         x11-apps/xlsclients
56         x11-apps/xmodmap
57         x11-apps/xpr
58         x11-apps/xprop
59         x11-apps/xrandr
60         x11-apps/xrdb
61         x11-apps/xrefresh
62         x11-apps/xset
63         x11-apps/xsetroot
64         x11-apps/xvinfo
65         x11-apps/xwd
66         x11-apps/xwininfo
67         x11-apps/xwud
68         "
69
70 # Data
71 RDEPEND="${RDEPEND}
72         x11-misc/xbitmaps
73         x11-themes/xcursor-themes
74         "
75
76 # Utilities
77 RDEPEND="${RDEPEND}
78         x11-misc/makedepend
79         x11-misc/util-macros
80         "
81
82 # Fonts
83 RDEPEND="${RDEPEND}
84         media-fonts/font-adobe-100dpi
85         media-fonts/font-adobe-75dpi
86         media-fonts/font-adobe-utopia-100dpi
87         media-fonts/font-adobe-utopia-75dpi
88         media-fonts/font-adobe-utopia-type1
89         media-fonts/font-alias
90         media-fonts/font-arabic-misc
91         bh-fonts? (
92                 media-fonts/font-bh-100dpi
93                 media-fonts/font-bh-75dpi
94                 media-fonts/font-bh-lucidatypewriter-100dpi
95                 media-fonts/font-bh-lucidatypewriter-75dpi
96                 media-fonts/font-bh-ttf
97                 media-fonts/font-bh-type1
98         )
99         media-fonts/font-bitstream-100dpi
100         media-fonts/font-bitstream-75dpi
101         media-fonts/font-bitstream-speedo
102         media-fonts/font-bitstream-type1
103         media-fonts/font-cronyx-cyrillic
104         media-fonts/font-cursor-misc
105         media-fonts/font-daewoo-misc
106         media-fonts/font-dec-misc
107         media-fonts/font-ibm-type1
108         media-fonts/font-isas-misc
109         media-fonts/font-jis-misc
110         media-fonts/font-micro-misc
111         media-fonts/font-misc-cyrillic
112         media-fonts/font-misc-ethiopic
113         media-fonts/font-misc-meltho
114         media-fonts/font-misc-misc
115         media-fonts/font-mutt-misc
116         media-fonts/font-schumacher-misc
117         media-fonts/font-screen-cyrillic
118         media-fonts/font-sony-misc
119         media-fonts/font-sun-misc
120         media-fonts/font-util
121         media-fonts/font-winitzki-cyrillic
122         media-fonts/font-xfree86-type1
123
124         media-fonts/font-alias
125         media-fonts/font-util
126         media-fonts/encodings
127         "
128
129 DEPEND="${RDEPEND}"
130
131 pkg_preinst() {
132         # Save xorg.conf because of bug #278268
133         if [[ -f "${ROOT}etc/X11/xorg.conf" ]]; then
134                 cp "${ROOT}etc/X11/xorg.conf" "${T}"
135         fi
136 }
137
138 pkg_postinst() {
139         # Restore saved xorg.conf
140         if [[ -f "${T}/xorg.conf" ]]; then
141                 cp "${T}/xorg.conf" "${ROOT}etc/X11/xorg.conf"
142         fi
143
144         elog
145         elog "Please note that the xcursors are in ${ROOT}usr/share/cursors/${PN}."
146         elog "Any custom cursor sets should be placed in that directory."
147         elog
148         elog "If you wish to set system-wide default cursors, please create"
149         elog "${ROOT}usr/local/share/cursors/${PN}/default/index.theme"
150         elog "with content: \"Inherits=theme_name\" so that future"
151         elog "emerges will not overwrite those settings."
152         elog
153         elog "Listening on TCP is disabled by default with startx."
154         elog "To enable it, edit ${ROOT}usr/bin/startx."
155         elog
156
157         # (#76985)
158         elog "Visit https://wiki.gentoo.org/wiki/Category:X.Org"
159         elog "for more information on configuring X."
160         elog
161 }