]> git.draconx.ca Git - gentoo-fixes.git/blob - media-plugins/gimp-resynthesizer/gimp-resynthesizer-2.0.3-r3.ebuild
media-plugins/gimp-resynthesizer: Resurrect.
[gentoo-fixes.git] / media-plugins / gimp-resynthesizer / gimp-resynthesizer-2.0.3-r3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit autotools python-single-r1
9
10 MY_PN="${PN#gimp-}"
11 MY_P="${MY_PN}-${PV}"
12
13 DESCRIPTION="Suite of GIMP plugins for texture synthesis"
14 HOMEPAGE="https://github.com/bootchk/resynthesizer"
15 SRC_URI="https://github.com/bootchk/resynthesizer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
16
17 LICENSE="GPL-3"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE=""
21 REQUIRED_USE=${PYTHON_REQUIRED_USE}
22
23 DEPEND="media-gfx/gimp
24         virtual/pkgconfig
25         ${PYTHON_DEPS}"
26 RDEPEND="media-gfx/gimp[python(-),${PYTHON_SINGLE_USEDEP}]
27         ${PYTHON_DEPS}"
28
29 S="${WORKDIR}/${MY_P}"
30
31 src_prepare() {
32         default
33         eautoreconf
34 }