]> git.draconx.ca Git - gentoo-fixes.git/blob - x11-base/xorg-x11/xorg-x11-7.4-r5.ebuild
app-emulation/wine-vanilla-4.0.4: Adapt mpg123 dependency.
[gentoo-fixes.git] / x11-base / xorg-x11 / xorg-x11-7.4-r5.ebuild
1 # This ebuild is a modified version of the work originally distributed with
2 # Gentoo GNU/Linux, covered by the following copyright and permission notice:
3 #
4 #   Copyright 1999-2020 Gentoo Authors
5 #   Distributed under the terms of the GNU General Public License v2
6 #
7 # The modifications are:
8 #
9 #   * Add bh-fonts USE flag to avoid installing nonfree B&H fonts (2014-09)
10 #   * Remove dependency on unsupported bitstreem-speedo fonts (2023-05)
11 #   * Remove dependency on xf86dga application (2023-07)
12
13 EAPI=6
14
15 DESCRIPTION="An X11 implementation maintained by the X.Org Foundation (meta package)"
16 HOMEPAGE="https://www.x.org/wiki/"
17
18 LICENSE="metapackage"
19 SLOT="0"
20 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
21 IUSE="+fonts bh-fonts"
22
23 REQUIRED_USE="bh-fonts? ( fonts )"
24
25 # Server
26 RDEPEND="${RDEPEND}
27         x11-base/xorg-server[-minimal]"
28
29 # Applications
30 RDEPEND="${RDEPEND}
31         x11-apps/appres
32         x11-apps/bitmap
33         x11-apps/iceauth
34         x11-apps/luit
35         >=x11-apps/mkfontscale-1.2.0
36         x11-apps/sessreg
37         x11-apps/setxkbmap
38         x11-apps/smproxy
39         x11-apps/x11perf
40         x11-apps/xauth
41         || ( x11-apps/xbacklight sys-power/acpilight )
42         x11-apps/xcmsdb
43         x11-apps/xcursorgen
44         x11-apps/xdpyinfo
45         x11-apps/xdriinfo
46         x11-apps/xev
47         x11-apps/xgamma
48         x11-apps/xhost
49         x11-apps/xinput
50         x11-apps/xkbcomp
51         x11-apps/xkbevd
52         x11-apps/xkbutils
53         x11-apps/xkill
54         x11-apps/xlsatoms
55         x11-apps/xlsclients
56         x11-apps/xmodmap
57         x11-apps/xpr
58         x11-apps/xprop
59         x11-apps/xrandr
60         x11-apps/xrdb
61         x11-apps/xrefresh
62         x11-apps/xset
63         x11-apps/xsetroot
64         x11-apps/xvinfo
65         x11-apps/xwd
66         x11-apps/xwininfo
67         x11-apps/xwud
68         "
69
70 # Data
71 RDEPEND="${RDEPEND}
72         x11-misc/xbitmaps
73         x11-themes/xcursor-themes
74         "
75
76 # Utilities
77 RDEPEND="${RDEPEND}
78         x11-misc/makedepend
79         x11-misc/util-macros
80         "
81
82 # Fonts
83 RDEPEND="${RDEPEND}
84         fonts? (
85                 media-fonts/font-adobe-100dpi
86                 media-fonts/font-adobe-75dpi
87                 media-fonts/font-adobe-utopia-100dpi
88                 media-fonts/font-adobe-utopia-75dpi
89                 media-fonts/font-adobe-utopia-type1
90                 media-fonts/font-alias
91                 media-fonts/font-arabic-misc
92                 bh-fonts? (
93                         media-fonts/font-bh-100dpi
94                         media-fonts/font-bh-75dpi
95                         media-fonts/font-bh-lucidatypewriter-100dpi
96                         media-fonts/font-bh-lucidatypewriter-75dpi
97                         media-fonts/font-bh-ttf
98                         media-fonts/font-bh-type1
99                 )
100                 media-fonts/font-bitstream-100dpi
101                 media-fonts/font-bitstream-75dpi
102                 media-fonts/font-bitstream-type1
103                 media-fonts/font-cronyx-cyrillic
104                 media-fonts/font-cursor-misc
105                 media-fonts/font-daewoo-misc
106                 media-fonts/font-dec-misc
107                 media-fonts/font-ibm-type1
108                 media-fonts/font-isas-misc
109                 media-fonts/font-jis-misc
110                 media-fonts/font-micro-misc
111                 media-fonts/font-misc-cyrillic
112                 media-fonts/font-misc-ethiopic
113                 media-fonts/font-misc-meltho
114                 media-fonts/font-misc-misc
115                 media-fonts/font-mutt-misc
116                 media-fonts/font-schumacher-misc
117                 media-fonts/font-screen-cyrillic
118                 media-fonts/font-sony-misc
119                 media-fonts/font-sun-misc
120                 media-fonts/font-util
121                 media-fonts/font-winitzki-cyrillic
122                 media-fonts/font-xfree86-type1
123
124                 media-fonts/font-alias
125                 media-fonts/font-util
126                 media-fonts/encodings
127         )
128         "
129
130 DEPEND="${RDEPEND}"
131
132 pkg_postinst() {
133         elog
134         elog "Please note that the xcursors are in ${EROOT%/}/usr/share/cursors/${PN}."
135         elog "Any custom cursor sets should be placed in that directory."
136         elog
137         elog "If you wish to set system-wide default cursors, please create"
138         elog "${EROOT%/}/usr/local/share/cursors/${PN}/default/index.theme"
139         elog "with content: \"Inherits=theme_name\" so that future"
140         elog "emerges will not overwrite those settings."
141         elog
142         elog "Listening on TCP is disabled by default with startx."
143         elog "To enable it, edit ${EROOT%/}/usr/bin/startx."
144         elog
145
146         elog "Visit https://wiki.gentoo.org/wiki/Category:X.Org"
147         elog "for more information on configuring X."
148         elog
149 }