]> git.draconx.ca Git - gentoo-fixes.git/blob - net-nntp/pan/pan-0.149.ebuild
app-emulation/wine-vanilla-4.0.4: Adapt mpg123 dependency.
[gentoo-fixes.git] / net-nntp / pan / pan-0.149.ebuild
1 # This ebuild is a modified version of the work originally distributed with
2 # Gentoo GNU/Linux, covered by the following copyright and permission notice:
3 #
4 #   Copyright 1999-2020 Gentoo Authors
5 #   Distributed under the terms of the GNU General Public License v2
6 #
7 # The modifications are:
8 #
9 #   * Update for gmime-3 support in newer pan (2022-06)
10
11 EAPI=6
12 inherit gnome2
13
14 DESCRIPTION="A newsreader for GNOME"
15 HOMEPAGE="http://pan.rebelbase.com/"
16 SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/source/${P}.tar.bz2"
17
18 LICENSE="GPL-2"
19 SLOT="0"
20 KEYWORDS="~alpha amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
21 IUSE="dbus gnome-keyring libnotify spell ssl"
22
23 RDEPEND="
24         >=dev-libs/glib-2.26:2
25         dev-libs/gmime:3.0
26         >=sys-libs/zlib-1.2.0
27         >=x11-libs/gtk+-2.16:2
28         gnome-keyring? ( >=gnome-base/libgnome-keyring-3.2 )
29         libnotify? ( >=x11-libs/libnotify-0.4.1:0= )
30         spell? (
31                 >=app-text/enchant-1.6:0/0
32                 >=app-text/gtkspell-2.0.7:2 )
33         ssl? ( >=net-libs/gnutls-3:0= )
34 "
35 DEPEND="${RDEPEND}
36         app-text/yelp-tools
37         >=sys-devel/gettext-0.19.7
38         virtual/pkgconfig
39 "
40
41 src_configure() {
42         # Wait for webkitgtk4 support
43         # gtk3 support is still not ready (follow what Fedora does)
44         gnome2_src_configure \
45                 --with-yelp-tools \
46                 --without-gtk3 \
47                 --without-webkit \
48                 $(use_with dbus) \
49                 $(use_enable gnome-keyring gkr) \
50                 $(use_with spell gtkspell) \
51                 $(use_enable libnotify) \
52                 $(use_with ssl gnutls)
53 }