]> git.draconx.ca Git - gentoo-fixes.git/blob - dev-python/pygtk/pygtk-2.24.0-r8.ebuild
app-emulation/wine-vanilla-4.0.4: Adapt mpg123 dependency.
[gentoo-fixes.git] / dev-python / pygtk / pygtk-2.24.0-r8.ebuild
1 # Copyright © 2021 Nick Bowler
2 #
3 # License GPLv2+: GNU General Public License version 2 or any later version.
4 # This is free software: you are free to change and redistribute it.
5 # There is NO WARRANTY, to the extent permitted by law.
6 #
7 # This is a modified version of the original ebuild from Gentoo GNU/Linux,
8 # covered by the following copyright and permission notice:
9 #
10 #   Copyright 1999-2020 Gentoo Authors
11 #   Distributed under the terms of the GNU General Public License v2
12 #
13 # The modifications are:
14 #
15 #   * Resurrect python2 version (2020-11)
16 #   * Avoid python eclasses as there is no more python2 support (2022-12)
17
18 EAPI=7
19
20 GNOME_TARBALL_SUFFIX="bz2"
21
22 inherit autotools flag-o-matic virtualx gnome2
23
24 DESCRIPTION="GTK+2 bindings for Python"
25 HOMEPAGE="https://gitlab.gnome.org/Archive/pygtk"
26
27 LICENSE="LGPL-2.1"
28 SLOT="2"
29 KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
30 IUSE="doc examples test"
31
32 RESTRICT="!test? ( test )"
33
34 DEPEND=">=dev-libs/glib-2.8:2
35         >=x11-libs/pango-1.16
36         >=dev-libs/atk-1.12
37         >=x11-libs/gtk+-2.24:2
38         >=dev-python/pycairo-1.0.2:2[python_targets_python2_7(+)]
39         >=dev-python/pygobject-2.26.8-r53:2[python_targets_python2_7(+)]
40         >=gnome-base/libglade-2.5:2.0"
41 RDEPEND="$DEPEND
42         dev-lang/python:2.7"
43 BDEPEND="dev-lang/python:2.7
44         virtual/pkgconfig
45         doc? ( dev-libs/libxslt
46                 >=app-text/docbook-xsl-stylesheets-1.70.1 )"
47
48 PATCHES=(
49         # Fix declaration of codegen in .pc
50         "${FILESDIR}/${PN}-2.13.0-fix-codegen-location.patch"
51         "${FILESDIR}/${PN}-2.14.1-libdir-pc.patch"
52         # Fix leaks of Pango objects
53         "${FILESDIR}/${PN}-2.24.0-fix-leaks.patch"
54         # Fail when tests are failing, bug #391307
55         "${FILESDIR}/${PN}-2.24.0-test-fail.patch"
56         # Fix broken tests, https://bugzilla.gnome.org/show_bug.cgi?id=709304
57         "${FILESDIR}/${P}-test_dialog.patch"
58         # Fix build on Darwin
59         "${FILESDIR}/${PN}-2.24.0-quartz-objc.patch"
60         # x11-libs/pango-1.44
61         "${FILESDIR}/${PN}-2.24.0-pango-1.44.patch"
62 )
63
64 src_prepare() {
65         default
66
67         # Examples is handled "manually"
68         sed -e 's/\(SUBDIRS = .* \)examples/\1/' \
69                 -i Makefile.am Makefile.in || die
70
71         sed -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
72                 -i configure.ac || die #466968
73
74         AT_M4DIR="m4" eautoreconf
75 }
76
77 src_configure() {
78         use hppa && append-flags -ffunction-sections
79         myconf=(
80                 $(use_enable doc docs)
81                 --disable-numpy
82                 --with-glade
83                 --enable-thread
84                 PYTHON=python2.7
85         )
86
87         gnome2_src_configure "${myconf[@]}"
88 }
89
90 src_test() {
91         # Let tests pass without permissions problems, bug #245103
92         gnome2_environment_reset
93         unset DBUS_SESSION_BUS_ADDRESS
94
95         cd tests && virtx emake check-local
96 }
97
98 src_install() {
99         dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO
100
101         if use examples; then
102                 rm examples/Makefile* || die
103                 dodoc -r examples
104         fi
105
106         gnome2_src_install
107         find "${D}" -name '*.la' -type f -delete || die
108 }