]> git.draconx.ca Git - gentoo-fixes.git/blob - dev-python/pycairo/pycairo-1.18.2-r6.ebuild
app-emulation/wine-vanilla-4.0.4: Adapt mpg123 dependency.
[gentoo-fixes.git] / dev-python / pycairo / pycairo-1.18.2-r6.ebuild
1 # Copyright © 2020-2023 Nick Bowler
2 #
3 # License GPLv2+: GNU General Public License version 2 or any later version.
4 # This is free software: you are free to change and redistribute it.
5 # There is NO WARRANTY, to the extent permitted by law.
6 #
7 # This is a modified version of the original ebuild from Gentoo GNU/Linux,
8 # covered by the following copyright and permission notice:
9 #
10 #   Copyright 1999-2020 Gentoo Authors
11 #   Distributed under the terms of the GNU General Public License v2
12 #
13 # The modifications are:
14 #
15 #   * Resurrect python2 version installable alongside newer version (2020-11)
16 #   * Avoid python eclasses as there is no more python2 support (2022-12)
17 #   * Fix deps against newer cairo ebuilds w/o "svg" USE flag (2023-01)
18
19 EAPI=7
20
21 DESCRIPTION="Python bindings for the cairo library"
22 HOMEPAGE="https://www.cairographics.org/pycairo/ https://github.com/pygobject/pycairo"
23 SRC_URI="https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz"
24
25 LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
26 SLOT="2"
27 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
28 IUSE="examples"
29
30 # Strong block on old pycairo w/ python2 support because the merge will
31 # otherwise not work properly due to replacing a directory with a file.
32
33 DEPEND=">=x11-libs/cairo-1.13.1[svg(+)]
34         !!dev-python/pycairo:0[python_targets_python2_7]"
35 RDEPEND="$DEPEND
36         dev-lang/python:2.7[threads(+)]"
37 BDEPEND="dev-lang/python:2.7"
38
39 PATCHES=(
40         "$FILESDIR/$P-no-setuptools.patch"
41         "$FILESDIR/$PN-1.19.1-py39.patch"
42 )
43
44 src_compile () {
45         python2.7 setup.py build || die
46 }
47
48 src_install () {
49         default
50
51         if use examples; then
52                 dodoc -r examples
53         fi
54
55         python2.7 setup.py install --skip-build --root="$D" || die
56 }