]> git.draconx.ca Git - gentoo-fixes.git/blob - media-plugins/gimp-resynthesizer/gimp-resynthesizer-2.0.3-r5.ebuild
Work around python-r1 eclass dropping python2.
[gentoo-fixes.git] / media-plugins / gimp-resynthesizer / gimp-resynthesizer-2.0.3-r5.ebuild
1 # Copyright © 2020-2021 Nick Bowler
2 #
3 # License GPLv2+: GNU General Public License version 2 or any later version.
4 # This is free software: you are free to change and redistribute it.
5 # There is NO WARRANTY, to the extent permitted by law.
6 #
7 # This is a modified version of the original ebuild from Gentoo GNU/Linux,
8 # covered by the following copyright and permission notice:
9 #
10 #   Copyright 1999-2020 Gentoo Authors
11 #   Distributed under the terms of the GNU General Public License v2
12
13 EAPI=7
14
15 _PYTHON_ALLOW_PY27=1
16 PYTHON_COMPAT=( python2_7 )
17
18 inherit autotools python-single-r1
19
20 MY_PN=${PN#gimp-}
21 MY_P=$MY_PN-$PV
22
23 DESCRIPTION="Suite of GIMP plugins for texture synthesis"
24 HOMEPAGE="https://github.com/bootchk/resynthesizer"
25 SRC_URI="https://github.com/bootchk/$MY_PN/archive/v$PV.tar.gz -> $P.tar.gz"
26
27 LICENSE="GPL-3"
28 SLOT="0"
29 KEYWORDS="~amd64 ~x86"
30
31 BDEPEND="virtual/pkgconfig"
32 DEPEND="$PYTHON_DEPS
33         || (
34                 media-plugins/gimp-python[$PYTHON_SINGLE_USEDEP]
35                 media-gfx/gimp[python(-),$PYTHON_SINGLE_USEDEP] )"
36 RDEPEND=$DEPEND
37 REQUIRED_USE=$PYTHON_REQUIRED_USE
38
39 S=$WORKDIR/$MY_P
40
41 src_prepare() {
42         default
43         eautoreconf
44 }