]> git.draconx.ca Git - gentoo-fixes.git/blob - dev-python/pycairo/pycairo-1.18.2-r5.ebuild
Remove python eclass usage from gimp plugin dependencies.
[gentoo-fixes.git] / dev-python / pycairo / pycairo-1.18.2-r5.ebuild
1 # Copyright © 2020-2022 Nick Bowler
2 #
3 # License GPLv2+: GNU General Public License version 2 or any later version.
4 # This is free software: you are free to change and redistribute it.
5 # There is NO WARRANTY, to the extent permitted by law.
6 #
7 # This is a modified version of the original ebuild from Gentoo GNU/Linux,
8 # covered by the following copyright and permission notice:
9 #
10 #   Copyright 1999-2020 Gentoo Authors
11 #   Distributed under the terms of the GNU General Public License v2
12 #
13 # The modifications are:
14 #
15 #   * Resurrect python2 version installable alongside newer version (2020-11)
16 #   * Avoid python eclasses as there is no more python2 support (2022-12)
17
18 EAPI=7
19
20 DESCRIPTION="Python bindings for the cairo library"
21 HOMEPAGE="https://www.cairographics.org/pycairo/ https://github.com/pygobject/pycairo"
22 SRC_URI="https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz"
23
24 LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
25 SLOT="2"
26 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
27 IUSE="examples"
28
29 # Strong block on old pycairo w/ python2 support because the merge will
30 # otherwise not work properly due to replacing a directory with a file.
31
32 DEPEND=">=x11-libs/cairo-1.13.1[svg]
33         !!dev-python/pycairo:0[python_targets_python2_7]"
34 RDEPEND="$DEPEND
35         dev-lang/python:2.7[threads(+)]"
36 BDEPEND="dev-lang/python:2.7"
37
38 PATCHES=(
39         "$FILESDIR/$P-no-setuptools.patch"
40         "$FILESDIR/$PN-1.19.1-py39.patch"
41 )
42
43 src_compile () {
44         python2.7 setup.py build || die
45 }
46
47 src_install () {
48         default
49
50         if use examples; then
51                 dodoc -r examples
52         fi
53
54         python2.7 setup.py install --skip-build --root="$D" || die
55 }