]> git.draconx.ca Git - gentoo-fixes.git/blob - x11-base/xorg-x11/xorg-x11-7.4-r3.ebuild
xorg-x11: Sync with upstream.
[gentoo-fixes.git] / x11-base / xorg-x11 / xorg-x11-7.4-r3.ebuild
1 # Copyright © 2014,2017-2018,2020 Nick Bowler
2 # License GPLv2+: GNU General Public License version 2 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5 #
6 # This a modified version of the original ebuild from Gentoo GNU/Linux,
7 # covered by the following copyright and permission notice:
8 #
9 #   Copyright 1999-2020 Gentoo Authors
10 #   Distributed under the terms of the GNU General Public License v2
11
12 EAPI=6
13
14 DESCRIPTION="An X11 implementation maintained by the X.Org Foundation (meta package)"
15 HOMEPAGE="https://www.x.org/wiki/"
16
17 LICENSE="metapackage"
18 SLOT="0"
19 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
20 IUSE="+fonts bh-fonts"
21
22 REQUIRED_USE="bh-fonts? ( fonts )"
23
24 # Server
25 RDEPEND="${RDEPEND}
26         x11-base/xorg-server[-minimal]"
27
28 # Applications
29 RDEPEND="${RDEPEND}
30         x11-apps/appres
31         x11-apps/bitmap
32         x11-apps/iceauth
33         x11-apps/luit
34         >=x11-apps/mkfontscale-1.2.0
35         x11-apps/sessreg
36         x11-apps/setxkbmap
37         x11-apps/smproxy
38         x11-apps/x11perf
39         x11-apps/xauth
40         || ( x11-apps/xbacklight sys-power/acpilight )
41         x11-apps/xcmsdb
42         x11-apps/xcursorgen
43         x11-apps/xdpyinfo
44         x11-apps/xdriinfo
45         x11-apps/xev
46         x11-apps/xf86dga
47         x11-apps/xgamma
48         x11-apps/xhost
49         x11-apps/xinput
50         x11-apps/xkbcomp
51         x11-apps/xkbevd
52         x11-apps/xkbutils
53         x11-apps/xkill
54         x11-apps/xlsatoms
55         x11-apps/xlsclients
56         x11-apps/xmodmap
57         x11-apps/xpr
58         x11-apps/xprop
59         x11-apps/xrandr
60         x11-apps/xrdb
61         x11-apps/xrefresh
62         x11-apps/xset
63         x11-apps/xsetroot
64         x11-apps/xvinfo
65         x11-apps/xwd
66         x11-apps/xwininfo
67         x11-apps/xwud
68         "
69
70 # Data
71 RDEPEND="${RDEPEND}
72         x11-misc/xbitmaps
73         x11-themes/xcursor-themes
74         "
75
76 # Utilities
77 RDEPEND="${RDEPEND}
78         x11-misc/makedepend
79         x11-misc/util-macros
80         "
81
82 # Fonts
83 RDEPEND="${RDEPEND}
84         fonts? (
85                 media-fonts/font-adobe-100dpi
86                 media-fonts/font-adobe-75dpi
87                 media-fonts/font-adobe-utopia-100dpi
88                 media-fonts/font-adobe-utopia-75dpi
89                 media-fonts/font-adobe-utopia-type1
90                 media-fonts/font-alias
91                 media-fonts/font-arabic-misc
92                 bh-fonts? (
93                         media-fonts/font-bh-100dpi
94                         media-fonts/font-bh-75dpi
95                         media-fonts/font-bh-lucidatypewriter-100dpi
96                         media-fonts/font-bh-lucidatypewriter-75dpi
97                         media-fonts/font-bh-ttf
98                         media-fonts/font-bh-type1
99                 )
100                 media-fonts/font-bitstream-100dpi
101                 media-fonts/font-bitstream-75dpi
102                 media-fonts/font-bitstream-speedo
103                 media-fonts/font-bitstream-type1
104                 media-fonts/font-cronyx-cyrillic
105                 media-fonts/font-cursor-misc
106                 media-fonts/font-daewoo-misc
107                 media-fonts/font-dec-misc
108                 media-fonts/font-ibm-type1
109                 media-fonts/font-isas-misc
110                 media-fonts/font-jis-misc
111                 media-fonts/font-micro-misc
112                 media-fonts/font-misc-cyrillic
113                 media-fonts/font-misc-ethiopic
114                 media-fonts/font-misc-meltho
115                 media-fonts/font-misc-misc
116                 media-fonts/font-mutt-misc
117                 media-fonts/font-schumacher-misc
118                 media-fonts/font-screen-cyrillic
119                 media-fonts/font-sony-misc
120                 media-fonts/font-sun-misc
121                 media-fonts/font-util
122                 media-fonts/font-winitzki-cyrillic
123                 media-fonts/font-xfree86-type1
124
125                 media-fonts/font-alias
126                 media-fonts/font-util
127                 media-fonts/encodings
128         )
129         "
130
131 DEPEND="${RDEPEND}"
132
133 pkg_postinst() {
134         elog
135         elog "Please note that the xcursors are in ${EROOT%/}/usr/share/cursors/${PN}."
136         elog "Any custom cursor sets should be placed in that directory."
137         elog
138         elog "If you wish to set system-wide default cursors, please create"
139         elog "${EROOT%/}/usr/local/share/cursors/${PN}/default/index.theme"
140         elog "with content: \"Inherits=theme_name\" so that future"
141         elog "emerges will not overwrite those settings."
142         elog
143         elog "Listening on TCP is disabled by default with startx."
144         elog "To enable it, edit ${EROOT%/}/usr/bin/startx."
145         elog
146
147         elog "Visit https://wiki.gentoo.org/wiki/Category:X.Org"
148         elog "for more information on configuring X."
149         elog
150 }