]> git.draconx.ca Git - gentoo-fixes.git/blob - sys-apps/man/man-1.6g-r2.ebuild
sys-apps/man: Use absolute paths in makewhatis cron job.
[gentoo-fixes.git] / sys-apps / man / man-1.6g-r2.ebuild
1 # Copyright © 2018 Nick Bowler
2 # License GPLv2+: GNU General Public License version 2 or any later version.
3 # This is free software: you are free to change and distribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5 #
6 # This a modified version of the original ebuild from Gentoo GNU/Linux,
7 # covered by the following copyright and permission notice:
8 #
9 #   Copyright 1999-2018 Gentoo Foundation
10 #   Distributed under the terms of the GNU General Public License v2
11
12 EAPI="6"
13
14 inherit eutils prefix toolchain-funcs user
15
16 DESCRIPTION="Standard commands to read man pages"
17 HOMEPAGE="http://primates.ximian.com/~flucifredi/man/"
18 SRC_URI="http://primates.ximian.com/~flucifredi/man/${P}.tar.gz"
19
20 LICENSE="GPL-2"
21 SLOT="0"
22 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
23 IUSE="+lzma nls selinux"
24
25 DEPEND="nls? ( sys-devel/gettext )"
26 RDEPEND="|| ( >=sys-apps/groff-1.19.2-r1 app-doc/heirloom-doctools )
27         !sys-apps/man-db
28         !<app-arch/lzma-4.63
29         lzma? ( app-arch/xz-utils )
30         selinux? ( sec-policy/selinux-makewhatis )"
31
32 pkg_setup() {
33         enewgroup man 15
34         enewuser man 13 -1 /usr/share/man man
35 }
36
37 PATCHES=(
38         "${FILESDIR}"/man-1.6f-man2html-compression-2.patch
39         "${FILESDIR}"/man-1.6-cross-compile.patch
40         "${FILESDIR}"/man-1.6f-unicode.patch #146315
41         "${FILESDIR}"/man-1.6c-cut-duplicate-manpaths.patch
42         "${FILESDIR}"/man-1.5m2-apropos.patch
43         "${FILESDIR}"/man-1.6g-fbsd.patch #138123
44         "${FILESDIR}"/man-1.6e-headers.patch
45         "${FILESDIR}"/man-1.6f-so-search-2.patch
46         "${FILESDIR}"/man-1.6g-compress.patch #205147
47         "${FILESDIR}"/man-1.6f-parallel-build.patch #207148 #258916
48         "${FILESDIR}"/man-1.6g-xz.patch #302380
49         "${FILESDIR}"/man-1.6f-makewhatis-compression-cleanup.patch #331979
50         "${FILESDIR}"/man-1.6g-nonportable-echo.patch #651038
51 )
52
53 src_prepare() {
54         # make sure `less` handles escape sequences #287183
55         sed -i -e '/^DEFAULTLESSOPT=/s:"$:R":' configure
56         default
57 }
58
59 echoit() { echo "$@" ; "$@" ; }
60 src_configure() {
61         strip-linguas $(eval $(grep ^LANGUAGES= configure) ; echo ${LANGUAGES//,/ })
62
63         unset NLSPATH #175258
64
65         tc-export CC BUILD_CC
66
67         local mylang=
68         if use nls ; then
69                 if [[ -z ${LINGUAS} ]] ; then
70                         mylang="all"
71                 else
72                         mylang="${LINGUAS// /,}"
73                 fi
74         else
75                 mylang="none"
76         fi
77         export COMPRESS
78         if use lzma ; then
79                 COMPRESS="${EPREFIX}"/usr/bin/xz
80         else
81                 COMPRESS="${EPREFIX}"/bin/bzip2
82         fi
83
84         if [[ -n ${EPREFIX} ]]; then
85                 hprefixify configure || die
86                 sed -i \
87                         -e "s/man_user=root/man_user=$(id -u)/"  \
88                         -e "s/man_group=man/man_group=$(id -g)/" \
89                         configure || die "Failed to disable suid/sgid options for man"
90                 sed -i -e 's:/usr/bin:@bindir@:' man2html/Makefile.in || die
91         fi
92
93         echoit \
94         ./configure \
95                 -prefix="$EPREFIX/usr" \
96                 -confdir="$EPREFIX/etc" \
97                 +sgid +fhs \
98                 +lang ${mylang} \
99                 || die "configure failed"
100
101         cat >makewhatis.cron <<EOF
102 #!/bin/sh
103
104 exec nice $EPREFIX/usr/sbin/makewhatis -u
105 EOF
106 }
107
108 src_install() {
109         unset NLSPATH #175258
110
111         emake PREFIX="${D}" install || die "make install failed"
112         dosym man /usr/bin/manpath
113
114         dodoc LSM README* TODO
115
116         # makewhatis only adds man-pages from the last 24hrs
117         exeinto /etc/cron.daily
118         newexe makewhatis.cron makewhatis
119
120         keepdir /var/cache/man
121         [[ -z ${EPREFIX} ]] && diropts -m0775 -g man
122         local mansects=$(grep ^MANSECT "${ED}"/etc/man.conf | cut -f2-)
123         for x in ${mansects//:/ } ; do
124                 keepdir /var/cache/man/cat${x}
125         done
126 }
127
128 pkg_postinst() {
129         einfo "Forcing sane permissions onto ${ROOT}var/cache/man (Bug #40322)"
130         chown -R root:man "${ROOT}"/var/cache/man
131         chmod -R g+w "${ROOT}"/var/cache/man
132         [[ -e ${ROOT}/var/cache/man/whatis ]] \
133                 && chown root:0 "${ROOT}"/var/cache/man/whatis
134
135         echo
136
137         if has_version app-doc/heirloom-doctools; then
138                 ewarn "Please note that the /etc/man.conf file installed will not"
139                 ewarn "work with heirloom's nroff by default (yet)."
140                 ewarn ""
141                 ewarn "Check app-doc/heirloom-doctools elog messages for the proper"
142                 ewarn "configuration."
143         fi
144 }