]> git.draconx.ca Git - gentoo-fixes.git/blob - media-plugins/gimp-resynthesizer/gimp-resynthesizer-2.0.3-r4.ebuild
media-plugins/gimp-resynthesizer: Update to work with gimp-python.
[gentoo-fixes.git] / media-plugins / gimp-resynthesizer / gimp-resynthesizer-2.0.3-r4.ebuild
1 # Copyright © 2020 Nick Bowler
2 #
3 # License GPLv2+: GNU General Public License version 2 or any later version.
4 # This is free software: you are free to change and redistribute it.
5 # There is NO WARRANTY, to the extent permitted by law.
6 #
7 # This is a modified version of the original ebuild from Gentoo GNU/Linux,
8 # covered by the following copyright and permission notice:
9 #
10 #   Copyright 1999-2020 Gentoo Authors
11 #   Distributed under the terms of the GNU General Public License v2
12
13 EAPI=7
14
15 PYTHON_COMPAT=( python2_7 )
16
17 inherit autotools python-single-r1
18
19 MY_PN=${PN#gimp-}
20 MY_P=$MY_PN-$PV
21
22 DESCRIPTION="Suite of GIMP plugins for texture synthesis"
23 HOMEPAGE="https://github.com/bootchk/resynthesizer"
24 SRC_URI="https://github.com/bootchk/$MY_PN/archive/v$PV.tar.gz -> $P.tar.gz"
25
26 LICENSE="GPL-3"
27 SLOT="0"
28 KEYWORDS="~amd64 ~x86"
29
30 BDEPEND="virtual/pkgconfig"
31 DEPEND="$PYTHON_DEPS
32         || (
33                 media-plugins/gimp-python[$PYTHON_SINGLE_USEDEP]
34                 media-gfx/gimp[python(-),$PYTHON_SINGLE_USEDEP] )"
35 RDEPEND=$DEPEND
36 REQUIRED_USE=$PYTHON_REQUIRED_USE
37
38 S=$WORKDIR/$MY_P
39
40 src_prepare() {
41         default
42         eautoreconf
43 }