]> git.draconx.ca Git - gentoo-fixes.git/blob - sys-devel/heirloom-devtools/heirloom-devtools-070527-r2.ebuild
Remove sci-electronics/gerbv.
[gentoo-fixes.git] / sys-devel / heirloom-devtools / heirloom-devtools-070527-r2.ebuild
1 # Copyright © 2018 Nick Bowler
2 # License GPLv2+: GNU General Public License version 2 or any later version.
3 # This is free software: you are free to change and distribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5 #
6 # This a modified version of the original ebuild from Gentoo GNU/Linux,
7 # covered by the following copyright and permission notice:
8 #
9 #   Copyright 1999-2017 Gentoo Foundation
10 #   Distributed under the terms of the GNU General Public License v2
11
12 EAPI=6
13 inherit flag-o-matic readme.gentoo-r1 toolchain-funcs
14
15 DESCRIPTION="Original UNIX development tools"
16 HOMEPAGE="http://heirloom.sourceforge.net/devtools.html"
17 SRC_URI="http://downloads.sourceforge.net/project/heirloom/${PN}/${PV}/${P}.tar.bz2"
18
19 LICENSE="BSD BSD-4 CDDL"
20 SLOT="0"
21 KEYWORDS="~amd64 ~x64-solaris"
22 IUSE=""
23
24 RDEPEND="app-shells/heirloom-sh
25         net-libs/libtirpc"
26 DEPEND="$RDEPEND
27         virtual/pkgconfig"
28
29 PATCHES=(
30         "$FILESDIR/$P-solaris.patch"
31         "$FILESDIR/$P-64-bit.patch"
32         "$FILESDIR/$P-gcc6.patch"
33 )
34
35 DOC_CONTENTS="
36         You may want to add /usr/5bin or /usr/ucb to \$PATH
37         to enable using the apps of heirloom toolchest by default.
38         Man pages are installed in /usr/share/man/5man/
39         You may need to set \$MANPATH to access them.
40 "
41
42 src_configure() {
43         pkgconfig=`tc-getPKG_CONFIG`
44         rpc_cppflags=`$pkgconfig --cflags libtirpc`
45         rpc_libs=`$pkgconfig --libs libtirpc`
46
47         sed -i \
48                 -e 's:^\(SHELL =\) \(.*\):\1 /bin/jsh:' \
49                 -e 's:^\(POSIX_SHELL =\) \(.*\):\1 /bin/sh:' \
50                 -e "s:^\(PREFIX=\)\(.*\):\1${EPREFIX}\2:" \
51                 -e "s:^\(SUSBIN=\)\(.*\):\1${EPREFIX}\2:" \
52                 -e "s:^\(LDFLAGS=\):\1${LDFLAGS}:" \
53                 -e "s:^\(CFLAGS=\)\(.*\):\1${CFLAGS}:" \
54                 -e 's:^\(STRIP=\)\(.*\):\1true:' \
55                 -e "s:^\(CXX = \)\(.*\):\1$(tc-getCXX) -fpermissive:" \
56                 -e "s:^\(INSTALL=\)\(.*\):\1$(which install):" \
57                 -e "/^CPPFLAGS *=/s:$: $rpc_cppflags:" \
58                 -e "/^LIBS *=/s:$: $rpc_libs:" \
59                 ./mk.config
60
61         echo "CC=$(tc-getCC)" >> "./mk.config"
62 }
63
64 src_compile() {
65         emake -j1
66 }
67
68 src_install() {
69         emake ROOT="${D}" install
70         readme.gentoo_create_doc
71 }
72
73 pkg_postinst() {
74         readme.gentoo_print_elog
75 }