]> git.draconx.ca Git - gentoo-draconx.git/blob - dev-util/cdecl99/cdecl99-1.2.ebuild
dev-util/cdecl99: Bump to version 1.2.
[gentoo-draconx.git] / dev-util / cdecl99 / cdecl99-1.2.ebuild
1 # Copyright © 2021-2022 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=7
7
8 DESCRIPTION="Explain and construct C declarations"
9 HOMEPAGE="http://draconx.ca/projects/cdecl99/"
10 SRC_URI="http://draconx.ca/archive/$PN/$P.tar.xz"
11
12 LICENSE="GPL-3+"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="static-libs nls readline"
16
17 RDEPEND="nls? ( virtual/libintl )
18         readline? ( sys-libs/readline:= )"
19 DEPEND="$RDEPEND"
20
21 src_configure () {
22         econf \
23                 --enable-shared $(use_enable static-libs static) \
24                 $(use_with readline) \
25                 $(use_enable nls)
26 }
27
28 src_install () {
29         default
30
31         use static-libs || find "$ED" -name '*.la' -delete
32 }