]> git.draconx.ca Git - gentoo-draconx.git/blob - dev-util/cdecl99/cdecl99-1.2.ebuild
dev-util/cdecl99: Fix 1.3 build when /bin/sh is bash-5.
[gentoo-draconx.git] / dev-util / cdecl99 / cdecl99-1.2.ebuild
1 # Copyright © 2021-2022 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=7
7
8 inherit multiprocessing
9
10 DESCRIPTION="Explain and construct C declarations"
11 HOMEPAGE="http://draconx.ca/projects/cdecl99/"
12 SRC_URI="http://draconx.ca/archive/$PN/$P.tar.xz"
13
14 LICENSE="GPL-3+"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~sparc ~x86"
17 IUSE="static-libs nls readline"
18
19 RDEPEND="nls? ( virtual/libintl )
20         readline? ( sys-libs/readline:= )"
21 DEPEND="$RDEPEND"
22
23 src_configure () {
24         econf \
25                 --enable-shared $(use_enable static-libs static) \
26                 $(use_with readline) \
27                 $(use_enable nls)
28 }
29
30 src_install () {
31         default
32
33         use static-libs || find "$ED" -name '*.la' -delete
34 }
35
36 src_test () {
37         emake TESTSUITEFLAGS="-j$(makeopts_jobs)" check
38 }