]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - dev-python/pygobject/pygobject-2.28.6-r58.ebuild
dev-python/pygobject: Adapt to more python2 disabling.
[gentoo-fixes.git] / dev-python / pygobject / pygobject-2.28.6-r58.ebuild
similarity index 78%
rename from dev-python/pygobject/pygobject-2.28.6-r57.ebuild
rename to dev-python/pygobject/pygobject-2.28.6-r58.ebuild
index 78e9cfeff7f3a6cdbbcfc27188352ba86b2d977c..255a005d5f490938018b692af72647c0bd8260fc 100644 (file)
@@ -20,13 +20,13 @@ PYTHON_COMPAT=( python2_7 )
 
 inherit autotools eutils gnome2 python-r1 virtualx
 
-DESCRIPTION="GLib's GObject library bindings for Python"
+DESCRIPTION="GLib's GObject library bindings for Python 2"
 HOMEPAGE="http://www.pygtk.org/"
 
 LICENSE="LGPL-2.1+"
 SLOT="2"
 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples libffi test"
+IUSE="examples libffi test +python_targets_python2_7"
 RESTRICT="!test? ( test )"
 REQUIRED_USE=$PYTHON_REQUIRED_USE
 
@@ -34,10 +34,9 @@ BDEPEND="virtual/pkgconfig
        dev-util/gtk-doc-am"
 
 RDEPEND=">=dev-libs/glib-2.24.0:2
-       dev-lang/python-exec:2
        libffi? ( dev-libs/libffi:= )
        !<dev-python/pygtk-2.23
-       $PYTHON_DEPS"
+       dev-lang/python:2.7"
 
 DEPEND="$RDEPEND
        test? (
@@ -80,13 +79,6 @@ src_prepare() {
        gnome2_src_prepare
 
        python_copy_sources
-       prepare_shebangs() {
-               # Make a backup with unconverted shebangs to keep python_doscript happy
-               cp codegen/codegen.py pygobject-codegen-2.0
-               sed -e "s%#! \?/usr/bin/env python%#!${PYTHON}%" \
-                       -i codegen/*.py || die "shebang convertion failed"
-       }
-       python_foreach_impl run_in_build_dir prepare_shebangs
 }
 
 src_configure() {
@@ -122,18 +114,7 @@ src_test() {
 }
 
 src_install() {
-       installing() {
-               local f prefixed_sitedir
-
-               gnome2_src_install
-
-               python_doscript pygobject-codegen-2.0
-
-               # Don't keep multiple copies of pygobject-codegen-2.0 script
-               prefixed_sitedir=$(python_get_sitedir)
-               dosym "${prefixed_sitedir#${EPREFIX}}/gtk-2.0/codegen/codegen.py" "/usr/lib/python-exec/${EPYTHON}/pygobject-codegen-2.0"
-       }
-       python_foreach_impl run_in_build_dir installing
+       python_foreach_impl run_in_build_dir gnome2_src_install
 
        if use examples; then
                insinto /usr/share/doc/${PF}