]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - app-emulation/wine-vanilla/wine-vanilla-4.0.4-r1.ebuild
app-emulation/wine-vanilla-4.0.4: Port to EAPI 8.
[gentoo-fixes.git] / app-emulation / wine-vanilla / wine-vanilla-4.0.4-r1.ebuild
similarity index 96%
rename from app-emulation/wine-vanilla/wine-vanilla-4.0.4.ebuild
rename to app-emulation/wine-vanilla/wine-vanilla-4.0.4-r1.ebuild
index c8112e655f54802952ee66ccb281ef090e79f7e2..1a5f201b0208d9ef51188cafcab6d22584689b7a 100644 (file)
@@ -1,12 +1,21 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
+# This ebuild is a modified version of the work originally distributed with
+# Gentoo GNU/Linux, covered by the following copyright and permission notice:
+#
+#   Copyright 1999-2021 Gentoo Authors
+#   Distributed under the terms of the GNU General Public License v2
+#
+# The modifications are:
+#
+#   * Apply patch to build successfully with Autoconf 2.71 (2021-11)
+#   * Build with -fcommon to get compatible behaviour from GCC 10 (2022-04)
+#   * Port to EAPI 8 for compatibility with current eclasses (2022-12)
+
+EAPI=8
 
 PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru si sk sl sr_RS@cyrillic sr_RS@latin sv ta te th tr uk wa zh_CN zh_TW"
 PLOCALE_BACKUP="en"
 
-inherit autotools eapi7-ver estack eutils flag-o-matic gnome2-utils multilib multilib-minimal pax-utils plocale toolchain-funcs virtualx xdg-utils
+inherit autotools estack flag-o-matic multilib multilib-minimal pax-utils plocale toolchain-funcs virtualx wrapper xdg-utils
 
 MY_PN="${PN%%-*}"
 MY_P="${MY_PN}-${PV}"
@@ -48,6 +57,10 @@ REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
 # or fail due to Xvfb's opengl limitations.
 RESTRICT="test"
 
+BDEPEND="virtual/pkgconfig
+       sys-devel/bison
+       sys-devel/flex"
+
 COMMON_DEPEND="
        X? (
                x11-libs/libXcursor[${MULTILIB_USEDEP}]
@@ -123,10 +136,7 @@ RDEPEND="${COMMON_DEPEND}
 
 # tools/make_requests requires perl
 DEPEND="${COMMON_DEPEND}
-       sys-devel/flex
        >=sys-kernel/linux-headers-2.6
-       virtual/pkgconfig
-       virtual/yacc
        X? ( x11-base/xorg-proto )
        prelink? ( sys-devel/prelink )
        xinerama? ( x11-base/xorg-proto )"