]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - dev-python/pycairo/pycairo-1.18.2-r6.ebuild
dev-python/pycairo: Fix cairo dependency.
[gentoo-fixes.git] / dev-python / pycairo / pycairo-1.18.2-r6.ebuild
similarity index 91%
rename from dev-python/pycairo/pycairo-1.18.2-r5.ebuild
rename to dev-python/pycairo/pycairo-1.18.2-r6.ebuild
index 07a0a4a82b3dfe7cce82baabe15ab6aa12c0f608..b6ad641f8a07e2ceb8816e1caef2e6e13a8f285e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright © 2020-2022 Nick Bowler
+# Copyright © 2020-2023 Nick Bowler
 #
 # License GPLv2+: GNU General Public License version 2 or any later version.
 # This is free software: you are free to change and redistribute it.
@@ -14,6 +14,7 @@
 #
 #   * Resurrect python2 version installable alongside newer version (2020-11)
 #   * Avoid python eclasses as there is no more python2 support (2022-12)
+#   * Fix deps against newer cairo ebuilds w/o "svg" USE flag (2023-01)
 
 EAPI=7
 
@@ -29,7 +30,7 @@ IUSE="examples"
 # Strong block on old pycairo w/ python2 support because the merge will
 # otherwise not work properly due to replacing a directory with a file.
 
-DEPEND=">=x11-libs/cairo-1.13.1[svg]
+DEPEND=">=x11-libs/cairo-1.13.1[svg(+)]
        !!dev-python/pycairo:0[python_targets_python2_7]"
 RDEPEND="$DEPEND
        dev-lang/python:2.7[threads(+)]"