]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - sys-apps/man/man-1.6g-r3.ebuild
sys-apps/man: Remove user.eclass usage.
[gentoo-fixes.git] / sys-apps / man / man-1.6g-r3.ebuild
similarity index 89%
rename from sys-apps/man/man-1.6g-r2.ebuild
rename to sys-apps/man/man-1.6g-r3.ebuild
index d4574946b723b23bfc4b3d43fbe348b1049f3a69..853c4af42c9c2bf4d11c21839dff8552da9ca39b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright © 2018 Nick Bowler
+# Copyright © 2018-2019, 2022 Nick Bowler
 # License GPLv2+: GNU General Public License version 2 or any later version.
 # This is free software: you are free to change and distribute it.
 # There is NO WARRANTY, to the extent permitted by law.
@@ -8,10 +8,17 @@
 #
 #   Copyright 1999-2018 Gentoo Foundation
 #   Distributed under the terms of the GNU General Public License v2
+#
+# The modifications are:
+#
+#   * Fix nonportable "echo" usage (2018-10)
+#   * Convert to EAPI 6 patch application (2019-03)
+#   * Improve /etc/cron.daily/makewhatis installation (2019-03)
+#   * Convert from user.eclass to GLEP 81 user/group packages (2022-12)
 
 EAPI="6"
 
-inherit eutils prefix toolchain-funcs user
+inherit eutils prefix toolchain-funcs
 
 DESCRIPTION="Standard commands to read man pages"
 HOMEPAGE="http://primates.ximian.com/~flucifredi/man/"
@@ -27,12 +34,9 @@ RDEPEND="|| ( >=sys-apps/groff-1.19.2-r1 app-doc/heirloom-doctools )
        !sys-apps/man-db
        !<app-arch/lzma-4.63
        lzma? ( app-arch/xz-utils )
-       selinux? ( sec-policy/selinux-makewhatis )"
-
-pkg_setup() {
-       enewgroup man 15
-       enewuser man 13 -1 /usr/share/man man
-}
+       selinux? ( sec-policy/selinux-makewhatis )
+       acct-group/man
+       acct-user/man"
 
 PATCHES=(
        "${FILESDIR}"/man-1.6f-man2html-compression-2.patch