]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - dev-python/pygtk/pygtk-2.24.0-r8.ebuild
Remove python eclass usage from gimp plugin dependencies.
[gentoo-fixes.git] / dev-python / pygtk / pygtk-2.24.0-r8.ebuild
similarity index 74%
rename from dev-python/pygtk/pygtk-2.24.0-r7.ebuild
rename to dev-python/pygtk/pygtk-2.24.0-r8.ebuild
index aa521c27e42a8071ca3d1476099757991e326f57..7bb2810ab9dd7bb251b959b8077576e362333515 100644 (file)
@@ -9,15 +9,17 @@
 #
 #   Copyright 1999-2020 Gentoo Authors
 #   Distributed under the terms of the GNU General Public License v2
+#
+# The modifications are:
+#
+#   * Resurrect python2 version (2020-11)
+#   * Avoid python eclasses as there is no more python2 support (2022-12)
 
 EAPI=7
 
 GNOME_TARBALL_SUFFIX="bz2"
 
-_PYTHON_ALLOW_PY27=1
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools flag-o-matic gnome2 python-r1 virtualx
+inherit autotools flag-o-matic virtualx gnome2
 
 DESCRIPTION="GTK+2 bindings for Python"
 HOMEPAGE="https://gitlab.gnome.org/Archive/pygtk"
@@ -25,8 +27,7 @@ HOMEPAGE="https://gitlab.gnome.org/Archive/pygtk"
 LICENSE="LGPL-2.1"
 SLOT="2"
 KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples test +python_targets_python2_7"
-REQUIRED_USE=$PYTHON_REQUIRED_USE
+IUSE="doc examples test"
 
 RESTRICT="!test? ( test )"
 
@@ -34,8 +35,8 @@ DEPEND=">=dev-libs/glib-2.8:2
        >=x11-libs/pango-1.16
        >=dev-libs/atk-1.12
        >=x11-libs/gtk+-2.24:2
-       >=dev-python/pycairo-1.0.2:2[$PYTHON_USEDEP]
-       >=dev-python/pygobject-2.26.8-r53:2[$PYTHON_USEDEP]
+       >=dev-python/pycairo-1.0.2:2[python_targets_python2_7(+)]
+       >=dev-python/pygobject-2.26.8-r53:2[python_targets_python2_7(+)]
        >=gnome-base/libglade-2.5:2.0"
 RDEPEND="$DEPEND
        dev-lang/python:2.7"
@@ -71,27 +72,19 @@ src_prepare() {
                -i configure.ac || die #466968
 
        AT_M4DIR="m4" eautoreconf
-
-       prepare_pygtk() {
-               mkdir -p "${BUILD_DIR}" || die
-       }
-       python_foreach_impl prepare_pygtk
 }
 
 src_configure() {
        use hppa && append-flags -ffunction-sections
-       configure_pygtk() {
-               ECONF_SOURCE="${S}" gnome2_src_configure \
-                       $(use_enable doc docs) \
-                       --disable-numpy \
-                       --with-glade \
-                       --enable-thread
-       }
-       python_foreach_impl run_in_build_dir configure_pygtk
-}
-
-src_compile() {
-       python_foreach_impl run_in_build_dir gnome2_src_compile
+       myconf=(
+               $(use_enable doc docs)
+               --disable-numpy
+               --with-glade
+               --enable-thread
+               PYTHON=python2.7
+       )
+
+       gnome2_src_configure "${myconf[@]}"
 }
 
 src_test() {
@@ -99,11 +92,7 @@ src_test() {
        gnome2_environment_reset
        unset DBUS_SESSION_BUS_ADDRESS
 
-       testing() {
-               cd tests
-               virtx emake check-local
-       }
-       python_foreach_impl run_in_build_dir testing
+       cd tests && virtx emake check-local
 }
 
 src_install() {
@@ -114,6 +103,6 @@ src_install() {
                dodoc -r examples
        fi
 
-       python_foreach_impl run_in_build_dir gnome2_src_install
+       gnome2_src_install
        find "${D}" -name '*.la' -type f -delete || die
 }