]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - dev-python/pygobject/pygobject-2.28.6-r59.ebuild
Remove python eclass usage from gimp plugin dependencies.
[gentoo-fixes.git] / dev-python / pygobject / pygobject-2.28.6-r59.ebuild
similarity index 78%
rename from dev-python/pygobject/pygobject-2.28.6-r58.ebuild
rename to dev-python/pygobject/pygobject-2.28.6-r59.ebuild
index 255a005d5f490938018b692af72647c0bd8260fc..4528fb8f406ecb98c4be58c91b45a3ee6927b4f3 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright © 2020-2021 Nick Bowler
+# Copyright © 2020-2022 Nick Bowler
 #
 # License GPLv2+: GNU General Public License version 2 or any later version.
 # This is free software: you are free to change and redistribute it.
@@ -9,16 +9,18 @@
 #
 #   Copyright 1999-2020 Gentoo Authors
 #   Distributed under the terms of the GNU General Public License v2
+#
+# The modifications are:
+#
+#   * Resurrect python2 version installable alongside newer version (2020-11)
+#   * Avoid python eclasses as there is no more python2 support (2022-12)
 
 EAPI=7
 
 GNOME2_LA_PUNT=yes
 GNOME2_EAUTORECONF=yes
 
-_PYTHON_ALLOW_PY27=1
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools eutils gnome2 python-r1 virtualx
+inherit autotools eutils virtualx gnome2
 
 DESCRIPTION="GLib's GObject library bindings for Python 2"
 HOMEPAGE="http://www.pygtk.org/"
@@ -26,9 +28,10 @@ HOMEPAGE="http://www.pygtk.org/"
 LICENSE="LGPL-2.1+"
 SLOT="2"
 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples libffi test +python_targets_python2_7"
-RESTRICT="!test? ( test )"
-REQUIRED_USE=$PYTHON_REQUIRED_USE
+IUSE="examples libffi test"
+
+# Tests seem to require network access which can't work.
+RESTRICT="test"
 
 BDEPEND="virtual/pkgconfig
        dev-util/gtk-doc-am"
@@ -77,8 +80,6 @@ src_prepare() {
                configure.ac || die
 
        gnome2_src_prepare
-
-       python_copy_sources
 }
 
 src_configure() {
@@ -90,34 +91,27 @@ src_configure() {
                --disable-introspection
                --disable-cairo
                $(use_with libffi ffi)
+               PYTHON=python2.7
        )
 
-       python_foreach_impl run_in_build_dir gnome2_src_configure "${myconf[@]}"
-}
-
-src_compile() {
-       python_foreach_impl run_in_build_dir gnome2_src_compile
+       gnome2_src_configure "${myconf[@]}"
 }
 
 # FIXME: With python multiple ABI support, tests return 1 even when they pass
 src_test() {
        unset DBUS_SESSION_BUS_ADDRESS
        export GIO_USE_VFS="local" # prevents odd issues with deleting ${T}/.gvfs
+       export XDG_CACHE_HOME="${T}/${EPYTHON}"
+
+       virtx emake -j1 check
 
-       testing() {
-               export XDG_CACHE_HOME="${T}/${EPYTHON}"
-               run_in_build_dir Xemake -j1 check
-               unset XDG_CACHE_HOME
-       }
-       python_foreach_impl testing
-       unset GIO_USE_VFS
+       unset XDG_CACHE_HOME GIO_USE_VFS
 }
 
 src_install() {
-       python_foreach_impl run_in_build_dir gnome2_src_install
+       gnome2_src_install
 
        if use examples; then
-               insinto /usr/share/doc/${PF}
-               doins -r examples
+               dodoc -r examples
        fi
 }