]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - dev-python/pycairo/pycairo-1.18.2-r5.ebuild
Remove python eclass usage from gimp plugin dependencies.
[gentoo-fixes.git] / dev-python / pycairo / pycairo-1.18.2-r5.ebuild
similarity index 61%
rename from dev-python/pycairo/pycairo-1.18.2-r4.ebuild
rename to dev-python/pycairo/pycairo-1.18.2-r5.ebuild
index a3e014b20bac80194d357065bfa0b28d6622abc9..07a0a4a82b3dfe7cce82baabe15ab6aa12c0f608 100644 (file)
@@ -9,16 +9,14 @@
 #
 #   Copyright 1999-2020 Gentoo Authors
 #   Distributed under the terms of the GNU General Public License v2
+#
+# The modifications are:
+#
+#   * Resurrect python2 version installable alongside newer version (2020-11)
+#   * Avoid python eclasses as there is no more python2 support (2022-12)
 
 EAPI=7
 
-_PYTHON_ALLOW_PY27=1
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads(+)"
-DISTUTILS_OPTIONAL=yes
-
-inherit distutils-r1
-
 DESCRIPTION="Python bindings for the cairo library"
 HOMEPAGE="https://www.cairographics.org/pycairo/ https://github.com/pygobject/pycairo"
 SRC_URI="https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz"
@@ -26,7 +24,7 @@ SRC_URI="https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz
 LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
 SLOT="2"
 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="examples +python_targets_python2_7"
+IUSE="examples"
 
 # Strong block on old pycairo w/ python2 support because the merge will
 # otherwise not work properly due to replacing a directory with a file.
@@ -34,43 +32,24 @@ IUSE="examples +python_targets_python2_7"
 DEPEND=">=x11-libs/cairo-1.13.1[svg]
        !!dev-python/pycairo:0[python_targets_python2_7]"
 RDEPEND="$DEPEND
-       dev-lang/python:2.7"
+       dev-lang/python:2.7[threads(+)]"
 BDEPEND="dev-lang/python:2.7"
 
-REQUIRED_USE=$PYTHON_REQUIRED_USE
-
 PATCHES=(
        "$FILESDIR/$P-no-setuptools.patch"
        "$FILESDIR/$PN-1.19.1-py39.patch"
 )
 
-distutils_enable_tests setup.py
-
-src_prepare () { default; distutils-r1_src_prepare; }
-
-python_compile () {
-       _distutils-r1_copy_egg_info
-       esetup.py build "$@"
+src_compile () {
+       python2.7 setup.py build || die
 }
 
-src_configure () { distutils-r1_src_configure; }
-src_compile ()   { distutils-r1_src_compile; }
-src_test ()      { distutils-r1_src_test; }
-src_install ()   { distutils-r1_src_install; }
-
-python_test() {
-       einfo "Skipping tests on Python 2 to unblock deps"
-}
-
-python_install() {
-       distutils-r1_python_install \
-               install_pkgconfig --pkgconfigdir="${EPREFIX}/usr/$(get_libdir)/pkgconfig"
-}
+src_install () {
+       default
 
-python_install_all() {
        if use examples; then
                dodoc -r examples
        fi
 
-       distutils-r1_python_install_all
+       python2.7 setup.py install --skip-build --root="$D" || die
 }