]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - dev-python/pycairo/pycairo-1.18.2-r4.ebuild
dev-python/pycairo: Adapt to more python2 disabling.
[gentoo-fixes.git] / dev-python / pycairo / pycairo-1.18.2-r4.ebuild
similarity index 75%
rename from dev-python/pycairo/pycairo-1.18.2-r3.ebuild
rename to dev-python/pycairo/pycairo-1.18.2-r4.ebuild
index a9338d31efc65633170473f6843a0aa34a5c1a48..6c2b8d13f73adb05a08879dd4c1054502241d5e3 100644 (file)
@@ -16,6 +16,7 @@ _PYTHON_ALLOW_PY27=1
 PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE="threads(+)"
 DISTUTILS_USE_SETUPTOOLS=no
+DISTUTILS_OPTIONAL=yes
 
 inherit distutils-r1
 
@@ -26,14 +27,18 @@ SRC_URI="https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz
 LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
 SLOT="2"
 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="examples"
+IUSE="examples +python_targets_python2_7"
 
 # Strong block on old pycairo w/ python2 support because the merge will
 # otherwise not work properly due to replacing a directory with a file.
 
-RDEPEND=">=x11-libs/cairo-1.13.1[svg]
+DEPEND=">=x11-libs/cairo-1.13.1[svg]
        !!dev-python/pycairo:0[python_targets_python2_7]"
-DEPEND=$RDEPEND
+RDEPEND="$DEPEND
+       dev-lang/python:2.7"
+BDEPEND="dev-lang/python:2.7"
+
+REQUIRED_USE=$PYTHON_REQUIRED_USE
 
 PATCHES=(
        "$FILESDIR/$P-no-setuptools.patch"
@@ -42,6 +47,18 @@ PATCHES=(
 
 distutils_enable_tests setup.py
 
+src_prepare () { default; distutils-r1_src_prepare; }
+
+python_compile () {
+       _distutils-r1_copy_egg_info
+       esetup.py build "$@"
+}
+
+src_configure () { distutils-r1_src_configure; }
+src_compile ()   { distutils-r1_src_compile; }
+src_test ()      { distutils-r1_src_test; }
+src_install ()   { distutils-r1_src_install; }
+
 python_test() {
        einfo "Skipping tests on Python 2 to unblock deps"
 }