]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - www-client/firefox/firefox-52.9.0-r3.ebuild
www-client/firefox: Update firefox-52.9.0 to EAPI 8.
[gentoo-fixes.git] / www-client / firefox / firefox-52.9.0-r3.ebuild
similarity index 97%
rename from www-client/firefox/firefox-52.9.0-r2.ebuild
rename to www-client/firefox/firefox-52.9.0-r3.ebuild
index f60ba25c7dae4164f2656eb8eb204cf37df8badf..5c08255066601c8576f6d40fbf0d115f1f0df7fb 100644 (file)
@@ -7,8 +7,9 @@
 # The modifications are:
 #
 #   * Apply patches to build on modern systems (2022-12)
+#   * Update to EAPI 8 (2023-04)
 
-EAPI=6
+EAPI=8
 VIRTUALX_REQUIRED="pgo"
 WANT_AUTOCONF="2.1"
 MOZ_ESR=1
@@ -37,7 +38,7 @@ MOZ_HTTP_URI="https://archive.mozilla.org/pub/${PN}/releases"
 MOZCONFIG_OPTIONAL_GTK2ONLY=1
 MOZCONFIG_OPTIONAL_WIFI=1
 
-inherit check-reqs flag-o-matic toolchain-funcs eutils gnome2-utils mozconfig-v6.52 pax-utils xdg-utils autotools virtualx mozlinguas-v2
+inherit check-reqs flag-o-matic toolchain-funcs desktop mozconfig-v6.52 pax-utils xdg-utils autotools virtualx mozlinguas-v2
 
 DESCRIPTION="Firefox Web Browser"
 HOMEPAGE="https://www.mozilla.org/firefox"
@@ -130,6 +131,8 @@ src_unpack() {
 }
 
 src_prepare() {
+       xdg_environment_reset
+
        # Apply our patches
        rm -f "${WORKDIR}"/firefox/2007_fix_nvidia_latest.patch
        eapply "${WORKDIR}/firefox"
@@ -264,8 +267,6 @@ src_compile() {
        if use pgo; then
                addpredict /root
                addpredict /etc/gconf
-               # Reset and cleanup environment variables used by GNOME/XDG
-               gnome2_environment_reset
 
                # Firefox tries to use dri stuff when it's run, see bug 380283
                shopt -s nullglob
@@ -381,8 +382,6 @@ PROFILE_EOF
 }
 
 pkg_preinst() {
-       gnome2_icon_savelist
-
        # if the apulse libs are available in MOZILLA_FIVE_HOME then apulse
        # doesn't need to be forced into the LD_LIBRARY_PATH
        if use pulseaudio && has_version ">=media-sound/apulse-0.1.9" ; then
@@ -403,7 +402,7 @@ pkg_preinst() {
 pkg_postinst() {
        # Update mimedb for the new .desktop file
        xdg_desktop_database_update
-       gnome2_icon_cache_update
+       xdg_icon_cache_update
 
        if ! use gmp-autoupdate && ! use eme-free ; then
                elog "USE='-gmp-autoupdate' has disabled the following plugins from updating or"
@@ -420,5 +419,6 @@ pkg_postinst() {
 }
 
 pkg_postrm() {
-       gnome2_icon_cache_update
+       xdg_desktop_database_update
+       xdg_icon_cache_update
 }