]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - net-nntp/pan/pan-0.149.ebuild
net-nntp/pan: Resurrect and bump ebuild.
[gentoo-fixes.git] / net-nntp / pan / pan-0.149.ebuild
diff --git a/net-nntp/pan/pan-0.149.ebuild b/net-nntp/pan/pan-0.149.ebuild
new file mode 100644 (file)
index 0000000..2915a7a
--- /dev/null
@@ -0,0 +1,53 @@
+# This ebuild is a modified version of the work originally distributed with
+# Gentoo GNU/Linux, covered by the following copyright and permission notice:
+#
+#   Copyright 1999-2020 Gentoo Authors
+#   Distributed under the terms of the GNU General Public License v2
+#
+# The modifications are:
+#
+#   * Update for gmime-3 support in newer pan (2022-06)
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A newsreader for GNOME"
+HOMEPAGE="http://pan.rebelbase.com/"
+SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dbus gnome-keyring libnotify spell ssl"
+
+RDEPEND="
+       >=dev-libs/glib-2.26:2
+       dev-libs/gmime:3.0
+       >=sys-libs/zlib-1.2.0
+       >=x11-libs/gtk+-2.16:2
+       gnome-keyring? ( >=gnome-base/libgnome-keyring-3.2 )
+       libnotify? ( >=x11-libs/libnotify-0.4.1:0= )
+       spell? (
+               >=app-text/enchant-1.6:0/0
+               >=app-text/gtkspell-2.0.7:2 )
+       ssl? ( >=net-libs/gnutls-3:0= )
+"
+DEPEND="${RDEPEND}
+       app-text/yelp-tools
+       >=sys-devel/gettext-0.19.7
+       virtual/pkgconfig
+"
+
+src_configure() {
+       # Wait for webkitgtk4 support
+       # gtk3 support is still not ready (follow what Fedora does)
+       gnome2_src_configure \
+               --with-yelp-tools \
+               --without-gtk3 \
+               --without-webkit \
+               $(use_with dbus) \
+               $(use_enable gnome-keyring gkr) \
+               $(use_with spell gtkspell) \
+               $(use_enable libnotify) \
+               $(use_with ssl gnutls)
+}