]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - dev-util/dialog/dialog-1.3.20201126.ebuild
dev-util/dialog: bump to 1.3.20201126
[gentoo-fixes.git] / dev-util / dialog / dialog-1.3.20201126.ebuild
diff --git a/dev-util/dialog/dialog-1.3.20201126.ebuild b/dev-util/dialog/dialog-1.3.20201126.ebuild
new file mode 100644 (file)
index 0000000..3810201
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIA_P=${PN}-$(ver_cut 1-2)-$(ver_cut 3)
+DESCRIPTION="tool to display dialog boxes from a shell"
+HOMEPAGE="https://invisible-island.net/dialog/"
+SRC_URI="https://invisible-island.net/datafiles/release/$PN.tar.gz -> $DIA_P.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/15"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
+IUSE="examples minimal nls static-libs unicode"
+
+RDEPEND="
+       >=sys-libs/ncurses-5.2-r5:=[unicode?]
+"
+DEPEND="
+       ${RDEPEND}
+       nls? ( sys-devel/gettext )
+       !minimal? ( sys-devel/libtool )
+"
+S=${WORKDIR}/${DIA_P}
+
+src_prepare() {
+       default
+       sed -i -e '/LIB_CREATE=/s:${CC}:& ${LDFLAGS}:g' configure || die
+       sed -i '/$(LIBTOOL_COMPILE)/s:$: $(LIBTOOL_OPTS):' makefile.in || die
+}
+
+src_configure() {
+       econf \
+               --disable-rpath-hack \
+               $(use_enable nls) \
+               $(use_with !minimal libtool) \
+               --with-libtool-opts=$(usex static-libs '' '-shared') \
+               --with-ncurses$(usex unicode w '')
+}
+
+src_install() {
+       use minimal && default || emake DESTDIR="${D}" install-full
+
+       use examples && dodoc -r samples
+
+       dodoc CHANGES README
+
+       find "${ED}" -name '*.la' -delete || die
+}