]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - x11-wm/fvwm/fvwm-2.6.9.ebuild
x11-wm/fvwm: Sync with upstream.
[gentoo-fixes.git] / x11-wm / fvwm / fvwm-2.6.9.ebuild
index 2f03c11a78e3f0f344b7795be715c74faab4167a..0ad1fcc5aa173ed5367332201f3f0ba0b255c2fa 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright © 2021 Nick Bowler
+# Copyright © 2021-2022 Nick Bowler
 # License GPLv2+: GNU General Public License version 2 or any later version.
 # This is free software: you are free to change and redistribute it.
 # There is NO WARRANTY, to the extent permitted by law.
@@ -6,19 +6,25 @@
 # This is a modified version of the original ebuild from Gentoo GNU/Linux,
 # covered by the following copyright and permission notice:
 #
-#   Copyright 1999-2020 Gentoo Authors
+#   Copyright 1999-2022 Gentoo Authors
 #   Distributed under the terms of the GNU General Public License v2
+#
+# The modifications include:
+#
+#   * patch build system to install bundled manpage (2021-02)
+#   * fix prefixed installation in src_install (2021-02)
+#   * convert patches to -p1 (2022-06)
 
 EAPI=7
 inherit autotools flag-o-matic desktop
 
 DESCRIPTION="An extremely powerful ICCCM-compliant multiple virtual desktop window manager"
-HOMEPAGE="http://www.fvwm.org/"
+HOMEPAGE="https://www.fvwm.org/"
 SRC_URI="https://github.com/fvwmorg/fvwm/releases/download/${PV}/${P}.tar.gz"
 
-LICENSE="GPL-2 FVWM"
+LICENSE="GPL-2+ FVWM"
 SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ppc ~ppc64 ~sparc x86"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ppc ~ppc64 ~riscv ~sparc x86"
 IUSE="bidi debug doc netpbm nls perl png readline rplay stroke svg tk truetype +vanilla xinerama lock"
 
 COMMON_DEPEND="
@@ -53,6 +59,7 @@ COMMON_DEPEND="
 "
 RDEPEND="${COMMON_DEPEND}
        dev-lang/perl
+       sys-apps/debianutils
        perl? ( tk? (
                        dev-lang/tk
                        dev-perl/Tk
@@ -61,8 +68,7 @@ RDEPEND="${COMMON_DEPEND}
        )
        rplay? ( media-sound/rplay )
        lock? ( x11-misc/xlockmore )
-       userland_GNU? ( sys-apps/debianutils )
-       !x86-fbsd? ( netpbm? ( media-libs/netpbm ) )
+       netpbm? ( media-libs/netpbm )
 "
 DEPEND="${COMMON_DEPEND}
        virtual/pkgconfig
@@ -70,25 +76,21 @@ DEPEND="${COMMON_DEPEND}
        doc? ( dev-libs/libxslt )
 "
 
-PATCHES=(      
+PATCHES=(
+       "$FILESDIR/$PN-2.6.5-ar.patch"      #474528
+       "$FILESDIR/$PN-2.6.8-perl528.patch" # Fix for Perl 5.28
        "$FILESDIR/$PN-2.6.9-respect-docdir.patch"
        "$FILESDIR/$PN-2.6.9-respect-htmldir.patch"
        "$FILESDIR/$PN-2.6.9-bundled-manpage.patch"
 )
-
 src_prepare() {
-       if ! use vanilla; then
+       use vanilla || PATCHES+=(
                # Enables fast translucent menus; patch from fvwm-user mailing list.
-               eapply -p0 "${FILESDIR}/${PN}-2.5.27-translucent-menus.diff"
+               "$FILESDIR/$PN-2.5.27-translucent-menus.diff"
 
                # Allow more mouse buttons, bug #411811
-               eapply -p0 "${FILESDIR}/${PN}-2.6.5-mouse-buttons.patch"
-       fi
-
-       eapply -p0 "${FILESDIR}/${PN}-2.6.5-ar.patch" #474528
-
-       # Fix for Perl 5.28
-       eapply -p0 "${FILESDIR}/${PN}-2.6.8-perl528.patch"
+               "$FILESDIR/$PN-2.6.5-mouse-buttons.patch"
+       )
 
        default
        eautoreconf