]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - sys-devel/heirloom-devtools/heirloom-devtools-070527-r2.ebuild
heirloom-devtools: Add -fpermissive to C++ flags.
[gentoo-fixes.git] / sys-devel / heirloom-devtools / heirloom-devtools-070527-r2.ebuild
index 55780b5d7f990e48a4b2889da7e9101a6a92d337..10dd856ec61f69d0377fff03f64d0a5e0aa1191c 100644 (file)
@@ -52,7 +52,7 @@ src_configure() {
                -e "s:^\(LDFLAGS=\):\1${LDFLAGS}:" \
                -e "s:^\(CFLAGS=\)\(.*\):\1${CFLAGS}:" \
                -e 's:^\(STRIP=\)\(.*\):\1true:' \
                -e "s:^\(LDFLAGS=\):\1${LDFLAGS}:" \
                -e "s:^\(CFLAGS=\)\(.*\):\1${CFLAGS}:" \
                -e 's:^\(STRIP=\)\(.*\):\1true:' \
-               -e "s:^\(CXX = \)\(.*\):\1$(tc-getCXX):" \
+               -e "s:^\(CXX = \)\(.*\):\1$(tc-getCXX) -fpermissive:" \
                -e "s:^\(INSTALL=\)\(.*\):\1$(which install):" \
                -e "/^CPPFLAGS *=/s:$: $rpc_cppflags:" \
                -e "/^LIBS *=/s:$: $rpc_libs:" \
                -e "s:^\(INSTALL=\)\(.*\):\1$(which install):" \
                -e "/^CPPFLAGS *=/s:$: $rpc_cppflags:" \
                -e "/^LIBS *=/s:$: $rpc_libs:" \