]> git.draconx.ca Git - gentoo-draconx.git/blob - media-plugins/gimp-plugin-export-layers/gimp-plugin-export-layers-3.3.1-r2.ebuild
Work around python-r1 eclass dropping python2.
[gentoo-draconx.git] / media-plugins / gimp-plugin-export-layers / gimp-plugin-export-layers-3.3.1-r2.ebuild
1 # Copyright © 2020-2021 Nick Bowler
2 #
3 # License GPLv3+: GNU General Public License version 3 or any later version.
4 # This is free software: you are free to change and redistribute it.
5 # There is NO WARRANTY, to the extent permitted by law.
6
7 EAPI=7
8
9 _PYTHON_ALLOW_PY27=1
10 PYTHON_COMPAT=( python2_7 )
11
12 inherit python-single-r1 multilib
13
14 DESCRIPTION="GIMP plug-in that exports layers as separate images"
15 HOMEPAGE="https://khalim19.github.io/gimp-plugin-export-layers/"
16 SRC_URI="https://github.com/khalim19/$PN/archive/$PV.tar.gz -> $P.tar.gz"
17
18 LICENSE="GPL-3+"
19 SLOT="0"
20 KEYWORDS="~amd64 ~x86"
21 REQUIRED_USE=$PYTHON_REQUIRED_USE
22
23 DEPEND=$PYTHON_DEPS
24 RDEPEND="$DEPEND
25         || (
26                 media-plugins/gimp-python[$PYTHON_SINGLE_USEDEP]
27                 media-gfx/gimp[python(-),$PYTHON_SINGLE_USEDEP] )"
28
29 src_install () {
30         local plugindir=/usr/$(get_libdir)/gimp/2.0/plug-ins
31         default
32
33         python_moduleinto "$plugindir"
34         python_domodule export_layers
35
36         exeinto "$plugindir"
37         doexe export_layers.py
38 }