]> git.draconx.ca Git - gentoo-draconx.git/blob - net-misc/caa-fetcher/caa-fetcher-1_p20190516.ebuild
media-sound/regainer: Update PYTHON_COMPAT.
[gentoo-draconx.git] / net-misc / caa-fetcher / caa-fetcher-1_p20190516.ebuild
1 # Copyright © 2018,2020 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=7
7
8 PYTHON_COMPAT=( python3_6 python3_7 )
9
10 inherit python-r1
11
12 SHA1=bb97b6559bf436b1a4bd6ec8303cceb9facf6e56
13
14 DESCRIPTION="Download album artwork from the Cover Art Archive"
15 SRC_URI="https://git.draconx.ca/gitweb/scripts.git/snapshot/$SHA1.tar.xz -> scripts-$SHA1.tar.xz"
16
17 LICENSE="WTFPL-2"
18 SLOT="0"
19 KEYWORDS="~amd64"
20 REQUIRED_USE=$PYTHON_REQUIRED_USE
21
22 RDEPEND="$PYTHON_DEPS
23         dev-python/python-musicbrainz-ngs[$PYTHON_USEDEP]"
24 DEPEND=$PYTHON_DEPS
25
26 S=$WORKDIR/$SHA1
27
28 src_install () {
29         python_foreach_impl python_newscript caa-fetcher.py caa-fetcher
30 }