]> git.draconx.ca Git - gentoo-draconx.git/blob - dev-python/portpicker/portpicker-1.4.0.ebuild
net-misc/google-cloud-sdk: New package.
[gentoo-draconx.git] / dev-python / portpicker / portpicker-1.4.0.ebuild
1 # Copyright © 2022 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=8
7
8 PYTHON_COMPAT=( python3_{9..10} )
9
10 DISTUTILS_USE_PEP517=setuptools
11
12 inherit distutils-r1
13
14 DESCRIPTION="Library to find available local network ports"
15 HOMEPAGE="https://github.com/google/python_portpicker https://pypi.org/project/portpicker/"
16 SRC_URI="mirror://pypi/${PN:0:1}/$PN/$P.tar.gz"
17
18 LICENSE="Apache-2.0"
19 SLOT="0"
20 KEYWORDS="~amd64 ~x86"
21
22 python_test () {
23         # Tests depend on portserver being imported as a module
24         distutils_install_for_testing --install-scripts=lib
25         epytest -s
26 }