]> git.draconx.ca Git - gentoo-draconx.git/blob - net-p2p/ipfilter/ipfilter-1822.ebuild
net-p2p/ipfilter: version bump.
[gentoo-draconx.git] / net-p2p / ipfilter / ipfilter-1822.ebuild
1 # Copyright © 2019 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=7
7
8 DESCRIPTION="IP filter list from eMule Security"
9 HOMEPAGE="http://www.emule-security.org/"
10 SRC_URI="http://upd.emule-security.org/ipfilter.zip -> $P.zip"
11
12 LICENSE="all-rights-reserved"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="+amule"
16
17 BDEPEND="|| ( app-arch/gzip app-arch/unzip )
18         app-text/dos2unix"
19
20 src_unpack() {
21         gunzip -c "$DISTDIR/$A" >ipfilter.dat && return
22         unzip "$DISTDIR/$A" && mv -f guarding.p2p ipfilter.dat && return
23         die "failed to unpack"
24 }
25
26 S=$WORKDIR
27
28 src_compile() {
29         dos2unix ipfilter.dat
30 }
31
32 src_install() {
33         insinto /usr/share
34         doins ipfilter.dat
35
36         if use amule; then
37                 dodir /usr/share/amule
38                 dosym ../ipfilter.dat /usr/share/amule/ipfilter.dat
39         fi
40 }