]> git.draconx.ca Git - gentoo-draconx.git/blob - net-misc/caa-fetcher/caa-fetcher-0.ebuild
Add ebuild for caa-fetcher
[gentoo-draconx.git] / net-misc / caa-fetcher / caa-fetcher-0.ebuild
1 # Copyright © 2018 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=6
7 PYTHON_COMPAT=( python3_6 )
8
9 inherit python-r1
10
11 SHA1=4ff20e03039c9e4abda2adf838b3ed323c766532
12
13 DESCRIPTION="Download album artwork from the Cover Art Archive"
14 SRC_URI="https://git.draconx.ca/gitweb/scripts.git/snapshot/$SHA1.tar.xz
15          -> scripts-$SHA1.tar.xz"
16
17 LICENSE="WTFPL-2"
18 SLOT="0"
19 KEYWORDS="~amd64"
20
21 RDEPEND="$PYTHON_DEPS
22         dev-python/python-musicbrainz-ngs[$PYTHON_USEDEP]"
23 DEPEND=$PYTHON_DEPS
24
25 S=$WORKDIR/$SHA1
26
27 src_install () {
28         python_foreach_impl python_newscript caa-fetcher.py caa-fetcher
29 }