]> git.draconx.ca Git - gentoo-draconx.git/blob - net-misc/google-cloud-sdk/google-cloud-sdk-405.0.0.ebuild
dev-python/prompt-toolkit: Deal with rename fallout.
[gentoo-draconx.git] / net-misc / google-cloud-sdk / google-cloud-sdk-405.0.0.ebuild
1 # Copyright © 2022-2023 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=8
7
8 PYTHON_COMPAT=(python3_10)
9
10 inherit python-r1
11
12 DESCRIPTION="Software for accessing Google cloud services"
13 HOMEPAGE="https://cloud.google.com/"
14 SRC_URI="amd64? ( https://dl.google.com/dl/cloudsdk/channels/rapid/downloads/$P-linux-x86_64.tar.gz )"
15
16 LICENSE="Apache-2.0"
17 SLOT="0"
18 KEYWORDS="~amd64"
19 REQUIRED_USE=$PYTHON_REQUIRED_USE
20
21 S=$WORKDIR/$PN
22
23 DEPEND="$PYTHON_DEPS
24         !dev-python/oauth2client:0
25         !dev-python/google-apitools:0"
26
27 RDEPEND="$DEPEND
28         <dev-python/prompt-toolkit-2[$PYTHON_USEDEP]
29         dev-python/argcomplete[$PYTHON_USEDEP]
30         dev-python/dnspython[$PYTHON_USEDEP]
31         dev-python/google-auth-httplib2[$PYTHON_USEDEP]
32         dev-python/google-auth-oauthlib[$PYTHON_USEDEP]
33         dev-python/ipaddr[$PYTHON_USEDEP]
34         dev-python/jsonschema[$PYTHON_USEDEP]
35         dev-python/portpicker[$PYTHON_USEDEP]
36         dev-python/proto-plus[$PYTHON_USEDEP]
37         dev-python/pyu2f[$PYTHON_USEDEP]
38         dev-python/ruamel-yaml[$PYTHON_USEDEP]
39         dev-python/six[$PYTHON_USEDEP]
40         dev-python/uritemplate[$PYTHON_USEDEP]
41         dev-python/websocket-client[$PYTHON_USEDEP]"
42
43 PDEPEND="dev-python/oauth2client:proxy
44         dev-python/google-apitools:proxy"
45
46 PDEPEND="dev-python/oauth2client:proxy
47         dev-python/google-apitools:proxy"
48
49 python_install () {
50         gcs_modules=(core calliope api_lib command_lib generated_clients *.py)
51
52         python_domodule lib/third_party/apitools lib/third_party/oauth2client
53         python_domodule lib/surface
54
55         python_moduleinto googlecloudsdk
56         python_domodule ${gcs_modules[@]/#/"lib/googlecloudsdk/"}
57
58         python_newscript lib/gcloud.py gcloud
59 }
60
61 src_install () {
62         default
63
64         python_foreach_impl python_install
65 }