]> git.draconx.ca Git - gentoo-draconx.git/blob - dev-python/prompt-toolkit/prompt-toolkit-1.0.18-r1.ebuild
dev-python/prompt-toolkit: Deal with rename fallout.
[gentoo-draconx.git] / dev-python / prompt-toolkit / prompt-toolkit-1.0.18-r1.ebuild
1 # Copyright © 2022 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=8
7
8 PYTHON_COMPAT=( python3_{9..11} )
9
10 inherit distutils-r1
11
12 MY_PN=${PN/-/_}
13 MY_P=$MY_PN-$PV
14
15 DESCRIPTION="Library for building powerful interactive command lines in Python"
16 HOMEPAGE="https://github.com/prompt-toolkit/python-prompt-toolkit https://pypi.org/project/prompt_toolkit/"
17 SRC_URI="mirror://pypi/${PN:0:1}/$PN/$MY_P.tar.gz"
18
19 LICENSE="BSD"
20 SLOT="0"
21 KEYWORDS="~amd64 ~x86"
22
23 RDEPEND="dev-python/six[$PYTHON_USEDEP]
24         dev-python/wcwidth[$PYTHON_USEDEP]"
25
26 S=$WORKDIR/$MY_P
27
28 distutils_enable_tests pytest