]> git.draconx.ca Git - gentoo-draconx.git/blob - media-plugins/gimp-plugin-export-layers/gimp-plugin-export-layers-3.3.1-r3.ebuild
gimp-python et al: Avoid python-exec dependency.
[gentoo-draconx.git] / media-plugins / gimp-plugin-export-layers / gimp-plugin-export-layers-3.3.1-r3.ebuild
1 # Copyright © 2020-2021 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=7
7
8 _PYTHON_ALLOW_PY27=1
9 PYTHON_COMPAT=( python2_7 )
10
11 inherit python-single-r1
12
13 DESCRIPTION="GIMP plug-in that exports layers as separate images"
14 HOMEPAGE="https://khalim19.github.io/gimp-plugin-export-layers/"
15 SRC_URI="https://github.com/khalim19/$PN/archive/$PV.tar.gz -> $P.tar.gz"
16
17 LICENSE="GPL-3+"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 REQUIRED_USE=$PYTHON_REQUIRED_USE
21
22 RDEPEND="dev-lang/python:2.7
23         || (
24                 media-plugins/gimp-python[$PYTHON_SINGLE_USEDEP]
25                 media-gfx/gimp[python(-),$PYTHON_SINGLE_USEDEP] )"
26
27 src_install () {
28         local plugindir=/usr/$(get_libdir)/gimp/2.0/plug-ins
29         default
30
31         python_moduleinto "$plugindir"
32         python_domodule export_layers
33
34         exeinto "$plugindir"
35         doexe export_layers.py
36 }