]> git.draconx.ca Git - gentoo-draconx.git/blob - x11-base/xorg-server/xorg-server-9999.ebuild
Remove libeatmydata.
[gentoo-draconx.git] / x11-base / xorg-server / xorg-server-9999.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 XORG_DOC=doc
8 inherit xorg-2 multilib versionator
9 EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
10
11 DESCRIPTION="X.Org X servers"
12 KEYWORDS=""
13
14 IUSE_SERVERS="dmx kdrive xnest xorg xvfb"
15 IUSE="${IUSE_SERVERS} ipv6 minimal nptl tslib +udev"
16
17 RDEPEND=">=app-admin/eselect-opengl-1.0.8
18         dev-libs/openssl
19         media-libs/freetype
20         >=x11-apps/iceauth-1.0.2
21         >=x11-apps/rgb-1.0.3
22         >=x11-apps/xauth-1.0.3
23         x11-apps/xkbcomp
24         >=x11-libs/libpciaccess-0.10.3
25         >=x11-libs/libXau-1.0.4
26         >=x11-libs/libXdmcp-1.0.2
27         >=x11-libs/libXfont-1.4.2
28         >=x11-libs/libxkbfile-1.0.4
29         >=x11-libs/pixman-0.21.8
30         >=x11-libs/xtrans-1.2.2
31         >=x11-misc/xbitmaps-1.0.1
32         >=x11-misc/xkeyboard-config-1.4
33         dmx? (
34                 x11-libs/libXt
35                 >=x11-libs/libdmx-1.0.99.1
36                 >=x11-libs/libX11-1.1.5
37                 >=x11-libs/libXaw-1.0.4
38                 >=x11-libs/libXext-1.0.99.4
39                 >=x11-libs/libXfixes-4.0.3
40                 >=x11-libs/libXi-1.2.99.1
41                 >=x11-libs/libXmu-1.0.3
42                 >=x11-libs/libXres-1.0.3
43                 >=x11-libs/libXtst-1.0.99.2
44         )
45         kdrive? (
46                 >=x11-libs/libXext-1.0.5
47                 x11-libs/libXv
48         )
49         !minimal? (
50                 >=x11-libs/libX11-1.1.5
51                 >=x11-libs/libXext-1.0.5
52                 >=media-libs/mesa-7.8_rc[nptl=]
53         )
54         tslib? ( >=x11-libs/tslib-1.0 x11-proto/xcalibrateproto )
55         udev? ( >=sys-fs/udev-150 )
56         >=x11-apps/xinit-1.3"
57
58 DEPEND="${RDEPEND}
59         sys-devel/flex
60         >=x11-proto/bigreqsproto-1.1.0
61         >=x11-proto/compositeproto-0.4
62         >=x11-proto/damageproto-1.1
63         >=x11-proto/fixesproto-4.1
64         >=x11-proto/fontsproto-2.0.2
65         >=x11-proto/glproto-1.4.11
66         >=x11-proto/inputproto-1.9.99.902
67         >=x11-proto/kbproto-1.0.3
68         >=x11-proto/randrproto-1.2.99.3
69         >=x11-proto/recordproto-1.13.99.1
70         >=x11-proto/renderproto-0.11
71         >=x11-proto/resourceproto-1.0.2
72         >=x11-proto/scrnsaverproto-1.1
73         >=x11-proto/trapproto-3.4.3
74         >=x11-proto/videoproto-2.2.2
75         >=x11-proto/xcmiscproto-1.2.0
76         >=x11-proto/xextproto-7.1.99
77         >=x11-proto/xf86dgaproto-2.0.99.1
78         >=x11-proto/xf86rushproto-1.1.2
79         >=x11-proto/xf86vidmodeproto-2.2.99.1
80         >=x11-proto/xineramaproto-1.1.3
81         >=x11-proto/xproto-7.0.17
82         dmx? (
83                 >=x11-proto/dmxproto-2.2.99.1
84                 doc? (
85                         || (
86                                 www-client/links
87                                 www-client/lynx
88                                 www-client/w3m
89                         )
90                 )
91         )
92         !minimal? (
93                 >=x11-proto/xf86driproto-2.1.0
94                 >=x11-proto/dri2proto-2.3
95                 >=x11-libs/libdrm-2.4.20
96         )"
97
98 PDEPEND="
99         xorg? ( x11-base/xorg-drivers )"
100
101 REQUIRED_USE="!minimal? (
102                 || ( ${IUSE_SERVERS} )
103         )"
104
105 #UPSTREAMED_PATCHES=(
106 #       "${WORKDIR}/patches/"
107 #)
108
109 PATCHES=(
110         "${UPSTREAMED_PATCHES[@]}"
111         "${FILESDIR}"/${PN}-disable-acpi.patch
112         "${FILESDIR}"/${PN}-1.9-nouveau-default.patch
113         "${FILESDIR}"/0001-xfree86-Add-DontLie-server-flag.patch
114         "${FILESDIR}"/0001-xaa-Free-the-scratch-pixmap-header-before-freeing-th.patch
115         "${FILESDIR}"/0002-Remove-the-cacheing-of-the-last-scratch-PixmapRec.patch
116         "${FILESDIR}"/0003-shm-Replace-open-coded-version-of-GetScratchPixmapHe.patch
117         "${FILESDIR}"/0004-shadow-Remove-unused-ModifyPixmapHeader-wrapping.patch
118 )
119
120 pkg_pretend() {
121         # older gcc is not supported
122         [[ $(gcc-major-version) -lt 4 ]] && \
123                 die "Sorry, but gcc earlier than 4.0 wont work for xorg-server."
124 }
125
126 pkg_setup() {
127         xorg-2_pkg_setup
128
129         # localstatedir is used for the log location; we need to override the default
130         #       from ebuild.sh
131         # sysconfdir is used for the xorg.conf location; same applies
132         #       --enable-install-setuid needed because sparcs default off
133         # NOTE: fop is used for doc generating ; and i have no idea if gentoo
134         #       package it somewhere
135         XORG_CONFIGURE_OPTIONS=(
136                 $(use_enable ipv6)
137                 $(use_enable dmx)
138                 $(use_enable kdrive)
139                 $(use_enable kdrive kdrive-kbd)
140                 $(use_enable kdrive kdrive-mouse)
141                 $(use_enable kdrive kdrive-evdev)
142                 $(use_enable tslib)
143                 $(use_enable tslib xcalibrate)
144                 $(use_enable !minimal record)
145                 $(use_enable !minimal xfree86-utils)
146                 $(use_enable !minimal install-libxf86config)
147                 $(use_enable !minimal dri)
148                 $(use_enable !minimal dri2)
149                 $(use_enable !minimal glx)
150                 $(use_enable xnest)
151                 $(use_enable xorg)
152                 $(use_enable xvfb)
153                 $(use_enable nptl glx-tls)
154                 $(use_enable udev config-udev)
155                 $(use_with doc doxygen)
156                 $(use_with doc xmlto)
157                 --sysconfdir=/etc/X11
158                 --localstatedir=/var
159                 --enable-install-setuid
160                 --with-fontrootdir=/usr/share/fonts
161                 --with-xkb-output=/var/lib/xkb
162                 --disable-config-hal
163                 --without-dtrace
164                 --without-fop
165                 --with-os-vendor=Gentoo
166         )
167
168         # Xorg-server requires includes from OS mesa which are not visible for
169         # users of binary drivers.
170         mkdir -p "${T}/mesa-symlinks/GL"
171         for i in gl glx glxmd glxproto glxtokens; do
172                 ln -s "${EROOT}usr/$(get_libdir)/opengl/xorg-x11/include/$i.h" "${T}/mesa-symlinks/GL/$i.h" || die
173         done
174         for i in glext glxext; do
175                 ln -s "${EROOT}usr/$(get_libdir)/opengl/global/include/$i.h" "${T}/mesa-symlinks/GL/$i.h" || die
176         done
177         append-cppflags "-I${T}/mesa-symlinks"
178 }
179
180 src_install() {
181         xorg-2_src_install
182
183         dynamic_libgl_install
184
185         server_based_install
186
187         if ! use minimal &&     use xorg; then
188                 # Install xorg.conf.example into docs
189                 dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
190         fi
191
192         newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
193         newinitd "${FILESDIR}"/xdm.initd-3 xdm
194         newconfd "${FILESDIR}"/xdm.confd-3 xdm
195
196         # install the @x11-module-rebuild set for Portage
197         insinto /usr/share/portage/config/sets
198         newins "${FILESDIR}"/xorg-sets.conf xorg.conf
199 }
200
201 pkg_postinst() {
202         # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
203         eselect opengl set xorg-x11 --use-old
204
205         if [[ ${PV} != 9999 && $(get_version_component_range 2 ${REPLACING_VERSIONS}) != $(get_version_component_range 2 ${PV}) ]]; then
206                 elog "You should consider reading upgrade guide for this release:"
207                 elog "  http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-$(get_version_component_range 1-2)-upgrade-guide.xml"
208                 echo
209                 ewarn "You must rebuild all drivers if upgrading from <xorg-server-$(get_version_component_range 1-2)"
210                 ewarn "because the ABI changed. If you cannot start X because"
211                 ewarn "of module version mismatch errors, this is your problem."
212
213                 echo
214                 ewarn "You can generate a list of all installed packages in the x11-drivers"
215                 ewarn "category using this command:"
216                 ewarn " emerge portage-utils; qlist -I -C x11-drivers/"
217                 ewarn "or using sets from portage-2.2:"
218                 ewarn " emerge @x11-module-rebuild"
219         fi
220 }
221
222 pkg_postrm() {
223         # Get rid of module dir to ensure opengl-update works properly
224         if [[ -z ${REPLACED_BY_VERSION} && -e ${ROOT}/usr/$(get_libdir)/xorg/modules ]]; then
225                 rm -rf "${ROOT}"/usr/$(get_libdir)/xorg/modules
226         fi
227 }
228
229 dynamic_libgl_install() {
230         # next section is to setup the dynamic libGL stuff
231         ebegin "Moving GL files for dynamic switching"
232                 dodir /usr/$(get_libdir)/opengl/xorg-x11/extensions
233                 local x=""
234                 for x in "${D}"/usr/$(get_libdir)/xorg/modules/extensions/lib{glx,dri,dri2}*; do
235                         if [ -f ${x} -o -L ${x} ]; then
236                                 mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/xorg-x11/extensions
237                         fi
238                 done
239         eend 0
240 }
241
242 server_based_install() {
243         if ! use xorg; then
244                 rm "${D}"/usr/share/man/man1/Xserver.1x \
245                         "${D}"/usr/$(get_libdir)/xserver/SecurityPolicy \
246                         "${D}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
247                         "${D}"/usr/share/man/man1/Xserver.1x
248         fi
249 }