]> git.draconx.ca Git - gentoo-draconx.git/blob - x11-libs/gtkextra/gtkextra-3.3.4.ebuild
Add ebuild for x11-libs/gtkextra.
[gentoo-draconx.git] / x11-libs / gtkextra / gtkextra-3.3.4.ebuild
1 # Copyright © 2021 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=7
7
8 DESCRIPTION="A useful set of widgets for creating GUIs for GTK+"
9 HOMEPAGE="http://gtkextra.sourceforge.net"
10 SRC_URI="mirror://sourceforge/$PN/$P.tar.gz"
11
12 LICENSE="LGPL-2+"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="doc +introspection"
16
17 DEPEND="introspection? ( dev-libs/gobject-introspection:= )
18         x11-libs/gtk+:2"
19 RDEPEND=$DEPEND
20
21 src_configure () {
22         args=(
23                 $(use_enable introspection)
24                 --disable-glade
25                 )
26
27         econf "${args[@]}"
28 }