]> git.draconx.ca Git - gentoo-draconx.git/blob - x11-drivers/xf86-video-intel/xf86-video-intel-2.11.0.ebuild
xf86-video-intel: Update Xv fix to the actual patches in git.
[gentoo-draconx.git] / x11-drivers / xf86-video-intel / xf86-video-intel-2.11.0.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-intel/xf86-video-intel-2.11.0.ebuild,v 1.1 2010/04/01 21:39:23 remi Exp $
4
5 EAPI=3
6
7 inherit linux-info xorg-2
8
9 DESCRIPTION="X.Org driver for Intel cards"
10
11 KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
12 IUSE="dri"
13
14 RDEPEND=">=x11-base/xorg-server-1.6
15         >=x11-libs/libdrm-2.4.16
16         x11-libs/libpciaccess
17         x11-libs/libXext
18         x11-libs/libXfixes
19         x11-libs/libXvMC
20         >=x11-libs/libxcb-1.5"
21 DEPEND="${RDEPEND}
22         >=x11-proto/dri2proto-1.99.3
23         x11-proto/fontsproto
24         x11-proto/randrproto
25         x11-proto/renderproto
26         x11-proto/xextproto
27         x11-proto/xproto
28         dri? ( x11-proto/xf86driproto
29                x11-proto/glproto )"
30
31 pkg_setup() {
32         xorg-2_pkg_setup
33         CONFIGURE_OPTIONS="$(use_enable dri) --enable-xvmc"
34 }
35
36 src_prepare() {
37         epatch "${FILESDIR}/0001-i965-Xv-fix-chroma-pitch.patch"
38         epatch "${FILESDIR}/0002-Xv-fixup-overlay-stride-confusion.patch"
39 }
40
41 pkg_postinst() {
42         if linux_config_exists \
43                 && ! linux_chkconfig_present DRM_I915_KMS; then
44                 echo
45                 ewarn "This driver requires KMS support in your kernel"
46                 ewarn "  Device Drivers --->"
47                 ewarn "    Graphics support --->"
48                 ewarn "      Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)  --->"
49                 ewarn "      <*>   Intel 830M, 845G, 852GM, 855GM, 865G (i915 driver)  --->"
50                 ewarn "              i915 driver"
51                 ewarn "      [*]       Enable modesetting on intel by default"
52                 echo
53         fi
54 }