]> git.draconx.ca Git - gentoo-draconx.git/blob - dev-python/prompt_toolkit/prompt_toolkit-1.0.18.ebuild
app-portage/squashmirror: Update PYTHON_COMPAT.
[gentoo-draconx.git] / dev-python / prompt_toolkit / prompt_toolkit-1.0.18.ebuild
1 # Copyright © 2022 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=8
7
8 PYTHON_COMPAT=( python3_{9..10} )
9
10 inherit distutils-r1
11
12 DESCRIPTION="Library for building powerful interactive command lines in Python"
13 HOMEPAGE="https://github.com/prompt-toolkit/python-prompt-toolkit https://pypi.org/project/prompt_toolkit/"
14 SRC_URI="mirror://pypi/${PN:0:1}/$PN/$P.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19
20 RDEPEND="dev-python/six[$PYTHON_USEDEP]
21         dev-python/wcwidth[$PYTHON_USEDEP]"
22
23 distutils_enable_tests pytest