]> git.draconx.ca Git - gentoo-draconx.git/blob - gnome-extra/evolution-mapi/evolution-mapi-3.30.5.ebuild
evolution-mapi: Bump to version 3.30.5
[gentoo-draconx.git] / gnome-extra / evolution-mapi / evolution-mapi-3.30.5.ebuild
1 # Copyright © 2016, 2018-2019 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # There is NO WARRANTY, to the extent permitted by law.
4
5 EAPI=6
6
7 inherit cmake-utils gnome2
8
9 DESCRIPTION="Evolution module for connecting to Microsoft Exchange"
10 HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
11
12 LICENSE="LGPL-3"
13 KEYWORDS="~amd64"
14 SLOT="0"
15
16 RDEPEND=">=gnome-extra/evolution-data-server-$PV:0=
17         >=mail-client/evolution-$PV:2.0
18         >=net-libs/libmapi-2
19         dev-libs/libical:="
20
21 DEPEND="$RDEPEND
22         virtual/pkgconfig"
23
24 src_prepare () {
25         cmake-utils_src_prepare
26
27         # Both cmake-utils_src_prepare and gnome2_src_prepare call default, which
28         # means patches get applied twice and that doesn't end well.  So redefine
29         # default to do nothing here, since it's already been run...
30         default () { :; }
31         gnome2_src_prepare
32 }
33
34 src_configure () {
35         cmake-utils_src_configure
36 }
37
38 src_compile () {
39         cmake-utils_src_compile
40 }
41
42 src_test () {
43         cmake-utils_src_test
44 }
45
46 src_install () {
47         cmake-utils_src_install
48 }