]> git.draconx.ca Git - gentoo-draconx.git/blob - x11-misc/xkeyboard-config/xkeyboard-config-2.1.ebuild
mathabx: Remove ebuild.
[gentoo-draconx.git] / x11-misc / xkeyboard-config / xkeyboard-config-2.1.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/xkeyboard-config-2.1.ebuild,v 1.7 2011/02/23 16:37:53 jer Exp $
4
5 EAPI=3
6
7 XORG_STATIC=no
8
9 inherit xorg-2
10
11 EGIT_REPO_URI="git://anongit.freedesktop.org/git/xkeyboard-config"
12
13 DESCRIPTION="X keyboard configuration database"
14 HOMEPAGE="http://www.freedesktop.org/wiki/Software/XKeyboardConfig"
15 [[ ${PV} == *9999* ]] || SRC_URI="${BASE_INDIVIDUAL_URI}/data/${PN}/${P}.tar.bz2"
16
17 KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~mips ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
18 IUSE=""
19
20 LICENSE="MIT"
21 SLOT="0"
22
23 RDEPEND="x11-apps/xkbcomp"
24 DEPEND="${RDEPEND}
25         >=dev-util/intltool-0.30
26         dev-perl/XML-Parser"
27
28 CONFIGURE_OPTIONS="
29         --with-xkb-base=\"${EPREFIX}/usr/share/X11/xkb\"
30         --enable-compat-rules
31         --with-xkb-rules-symlink=xorg"
32
33 src_prepare() {
34         epatch "${FILESDIR}"/0001-Add-option-to-bind-Control-modifier-to-CAPS-key-whil.patch
35 }
36
37 src_compile() {
38         # cleanup to make sure .dir files are regenerated
39         # bug #328455 c#26
40         emake clean || die
41         xorg-2_src_compile
42 }