]> git.draconx.ca Git - gentoo-draconx.git/blob - gnome-extra/evolution-mapi/evolution-mapi-3.24.5-r1.ebuild
evolution-mapi: Fix compatibility with libical-3
[gentoo-draconx.git] / gnome-extra / evolution-mapi / evolution-mapi-3.24.5-r1.ebuild
1 # Copyright © 2016, 2018-2019 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # There is NO WARRANTY, to the extent permitted by law.
4
5 EAPI=6
6
7 inherit cmake-utils gnome2
8
9 DESCRIPTION="Evolution module for connecting to Microsoft Exchange"
10 HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
11
12 LICENSE="LGPL-3"
13 KEYWORDS="~amd64"
14 SLOT="0"
15
16 RDEPEND=">=gnome-extra/evolution-data-server-$PV:0=
17         >=mail-client/evolution-$PV:2.0
18         >=net-libs/libmapi-2
19         dev-libs/libical:="
20
21 DEPEND="$RDEPEND
22         virtual/pkgconfig"
23
24 PATCHES=(
25         "$FILESDIR/$PN-3.24-libical-3.patch"
26 )
27
28 src_prepare () {
29         cmake-utils_src_prepare
30
31         # Both cmake-utils_src_prepare and gnome2_src_prepare call default, which
32         # means patches get applied twice and that doesn't end well.  So redefine
33         # default to do nothing here, since it's already been run...
34         default () { :; }
35         gnome2_src_prepare
36 }
37
38 src_configure () {
39         cmake-utils_src_configure
40 }
41
42 src_compile () {
43         cmake-utils_src_compile
44 }
45
46 src_test () {
47         cmake-utils_src_test
48 }
49
50 src_install () {
51         cmake-utils_src_install
52 }