]> git.draconx.ca Git - gentoo-draconx.git/blob - sci-electronics/lepton-eda/lepton-eda-1.9.14_p20210407.ebuild
sci-electronics/lepton-eda: Bump to version 1.9.14_p20210407
[gentoo-draconx.git] / sci-electronics / lepton-eda / lepton-eda-1.9.14_p20210407.ebuild
1 # Copyright © 2020-2021 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=7
7
8 inherit autotools xdg-utils
9
10 MY_P=$PN-${PV%_p*}
11
12 DESCRIPTION="Schematic capture and netlist utilities (fork of gEDA:gaf)"
13 HOMEPAGE="https://github.com/lepton-eda/lepton-eda"
14 SRC_URI="$HOMEPAGE/releases/download/${PV/_p/-}/$MY_P.tar.gz"
15
16 LICENSE="GPL-2+"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="doc nls stroke"
20
21 RDEPEND=">=dev-scheme/guile-2.0
22         >=x11-libs/gtk+-2.24:2
23         x11-libs/gtkextra
24         nls? ( virtual/libintl )
25         stroke? ( dev-libs/libstroke )"
26 DEPEND="$RDEPEND
27         doc? ( app-doc/doxygen )
28         nls? ( >=sys-devel/gettext-0.18 )
29         dev-util/desktop-file-utils
30         x11-misc/shared-mime-info
31         sys-apps/groff
32         virtual/pkgconfig"
33
34 S=$WORKDIR/$MY_P
35
36 PATCHES=("$FILESDIR/$PN-precompile.patch")
37
38 src_prepare () {
39         default
40         eautoreconf
41 }
42
43 src_configure () {
44         econf \
45                 $(use_enable doc doxygen) \
46                 $(use_enable nls) \
47                 $(use_with stroke libstroke) \
48                 --disable-update-xdg-database \
49                 --disable-rpath
50 }
51
52 src_install () {
53         default
54
55         GUILE_AUTO_COMPILE=0 LEPTON_INHIBIT_RC_FILES=1 \
56                 GUILE_LOAD_PATH=${ED%/}/usr/share/lepton-eda/scheme \
57                 LIBLEPTONGUI=${ED%/}/usr/$(get_libdir)/libleptongui \
58                 LIBLEPTON=${ED%/}/usr/$(get_libdir)/liblepton \
59                 emake bindir="${ED%/}/usr/bin" datadir="${ED%/}/usr/share" precompile
60 }
61
62 pkg_postinst () {
63         xdg_desktop_database_update
64         xdg_mimeinfo_database_update
65         xdg_icon_cache_update
66 }
67
68 pkg_postrm () {
69         pkg_postinst
70 }