]> git.draconx.ca Git - gentoo-draconx.git/blob - dev-util/fcode-utils/fcode-utils-1.0.3.ebuild
dev-util/fcode-utils: New package.
[gentoo-draconx.git] / dev-util / fcode-utils / fcode-utils-1.0.3.ebuild
1 # Copyright © 2022 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=8
7
8 inherit toolchain-funcs
9
10 DESCRIPTION="Utilities to process FCode bytecode for OpenFirmware"
11 HOMEPAGE="https://www.openfirmware.info/FCODE_suite"
12 SRC_URI="https://github.com/openbios/fcode-utils/archive/refs/tags/v$PV.tar.gz -> $P.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64"
17
18 src_compile () {
19         emake CC="$(tc-getCC)" CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" STRIP=:
20 }
21
22 src_install () {
23         dobin toke/toke detok/detok romheaders/romheaders
24
25         docinto html
26         dodoc documentation/*.html documentation/*.css
27 }