]> git.draconx.ca Git - gentoo-draconx.git/blob - media-plugins/gimp-plugin-export-layers/gimp-plugin-export-layers-3.3.1-r1.ebuild
Add media-plugins/gimp-python to maintain python support in GIMP.
[gentoo-draconx.git] / media-plugins / gimp-plugin-export-layers / gimp-plugin-export-layers-3.3.1-r1.ebuild
1 # Copyright © 2020 Nick Bowler
2 #
3 # License GPLv3+: GNU General Public License version 3 or any later version.
4 # This is free software: you are free to change and redistribute it.
5 # There is NO WARRANTY, to the extent permitted by law.
6
7 EAPI=7
8
9 PYTHON_COMPAT=( python2_7 )
10
11 inherit python-single-r1 multilib
12
13 DESCRIPTION="GIMP plug-in that exports layers as separate images"
14 HOMEPAGE="https://khalim19.github.io/gimp-plugin-export-layers/"
15 SRC_URI="https://github.com/khalim19/$PN/archive/$PV.tar.gz -> $P.tar.gz"
16
17 LICENSE="GPL-3+"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 REQUIRED_USE=$PYTHON_REQUIRED_USE
21
22 DEPEND=$PYTHON_DEPS
23 RDEPEND="$DEPEND
24         || (
25                 media-plugins/gimp-python[$PYTHON_SINGLE_USEDEP]
26                 media-gfx/gimp[python(-),$PYTHON_SINGLE_USEDEP] )"
27
28 src_install () {
29         local plugindir=/usr/$(get_libdir)/gimp/2.0/plug-ins
30         default
31
32         python_moduleinto "$plugindir"
33         python_domodule export_layers
34
35         exeinto "$plugindir"
36         doexe export_layers.py
37 }