]> git.draconx.ca Git - gentoo-draconx.git/blob - x11-libs/gdk-pixbuf-loader-webp/gdk-pixbuf-loader-webp-0.0.1.ebuild
gdk-pixbuf-loader-webp: New ebuild for released version 0.0.1.
[gentoo-draconx.git] / x11-libs / gdk-pixbuf-loader-webp / gdk-pixbuf-loader-webp-0.0.1.ebuild
1 # Copyright © 2020 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=7
7
8 inherit meson toolchain-funcs gnome2-utils multilib-minimal
9
10 MY_PN=webp-pixbuf-loader
11 MY_P=$MY_PN-$PV
12
13 DESCRIPTION="WebP loader for GdkPixbuf"
14 HOMEPAGE="https://github.com/aruiz/webp-pixbuf-loader/"
15 SRC_URI="https://github.com/aruiz/webp-pixbuf-loader/archive/0.0.1.tar.gz -> $MY_P.tar.gz"
16
17 LICENSE="GPL-2+"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20
21 RDEPEND="media-libs/libwebp:=[$MULTILIB_USEDEP]
22         x11-libs/gdk-pixbuf[$MULTILIB_USEDEP]"
23 DEPEND=$RDEPEND
24
25 S=$WORKDIR/$MY_P
26
27 multilib_src_configure () {
28         meson_src_configure
29 }
30
31 multilib_src_compile () {
32         meson_src_compile
33 }
34
35 multilib_src_install () {
36         local pkgconf=`tc-getPKG_CONFIG`
37         local moduledir=`$pkgconf --variable=gdk_pixbuf_moduledir gdk-pixbuf-2.0`
38
39         exeinto "$moduledir"
40         doexe libpixbufloader-webp.so
41 }
42
43 pkg_preinst () {
44         gnome2_gdk_pixbuf_savelist
45 }
46
47 pkg_postrm () {
48         gnome2_gdk_pixbuf_update
49 }
50
51 pkg_postinst () {
52         gnome2_gdk_pixbuf_update
53 }