]> git.draconx.ca Git - gentoo-draconx.git/blob - gnome-extra/evolution-mapi/evolution-mapi-3.24.5.ebuild
evolution-mapi: Bump and remove old.
[gentoo-draconx.git] / gnome-extra / evolution-mapi / evolution-mapi-3.24.5.ebuild
1 # Copyright © 2016, 2018-2019 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # There is NO WARRANTY, to the extent permitted by law.
4
5 EAPI=6
6
7 inherit cmake-utils gnome2
8
9 DESCRIPTION="Evolution module for connecting to Microsoft Exchange"
10 HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
11
12 LICENSE="LGPL-3"
13 KEYWORDS="~amd64"
14 SLOT="0"
15
16 RDEPEND=">=gnome-extra/evolution-data-server-$PV:0=
17         >=mail-client/evolution-$PV:2.0
18         >=net-libs/libmapi-2
19         <dev-libs/libical-3:="
20
21 DEPEND="$RDEPEND
22         virtual/pkgconfig"
23
24 src_prepare () {
25         cmake-utils_src_prepare
26         gnome2_src_prepare
27 }
28
29 src_configure () {
30         cmake-utils_src_configure
31 }
32
33 src_compile () {
34         cmake-utils_src_compile
35 }
36
37 src_test () {
38         cmake-utils_src_test
39 }
40
41 src_install () {
42         cmake-utils_src_install
43 }