]> git.draconx.ca Git - gentoo-draconx.git/blob - gnome-extra/evolution-mapi/evolution-mapi-3.44.2.ebuild
gnome-extra/evolution-mapi: Bump.
[gentoo-draconx.git] / gnome-extra / evolution-mapi / evolution-mapi-3.44.2.ebuild
1 # Copyright © 2016, 2018-2019, 2022 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=8
7
8 inherit gnome2 cmake
9
10 DESCRIPTION="Evolution module for connecting to Microsoft Exchange"
11 HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
12
13 LICENSE="LGPL-3"
14 KEYWORDS="~amd64"
15 SLOT="0"
16
17 RDEPEND=">=gnome-extra/evolution-data-server-$PV:0=
18         >=mail-client/evolution-$PV:2.0
19         >=net-libs/libmapi-2
20         dev-libs/libical:="
21
22 DEPEND="$RDEPEND
23         virtual/pkgconfig"
24
25 src_prepare () {
26         cmake_src_prepare
27
28         # Both cmake-utils_src_prepare and gnome2_src_prepare call default, which
29         # means patches get applied twice and that doesn't end well.  So redefine
30         # default to do nothing here, since it's already been run...
31         default () { :; }
32         gnome2_src_prepare
33 }