]> git.draconx.ca Git - gentoo-draconx.git/blob - dev-util/zcbor/zcbor-0.7.0.ebuild
dev-util/zcbor: new package.
[gentoo-draconx.git] / dev-util / zcbor / zcbor-0.7.0.ebuild
1 # Copyright © 2023 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=7
7
8 PYTHON_COMPAT=( python3_{10..11} )
9
10 inherit distutils-r1
11
12 DESCRIPTION="Tool for generating code from CDDL descriptions"
13 HOMEPAGE="https://github.com/NordicSemiconductor/zcbor"
14 SRC_URI="mirror://pypi/${PN:0:1}/$PN/$P.tar.gz"
15
16 LICENSE="Apache-2.0"
17 SLOT="0"
18 KEYWORDS="~amd64"
19
20 RDEPEND=">=dev-python/cbor2-5.4.3[$PYTHON_USEDEP]
21         >=dev-python/pyyaml-5.4.1[$PYTHON_USEDEP]
22         >=dev-python/regex-2022.3.15[$PYTHON_USEDEP]"