]> git.draconx.ca Git - gentoo-draconx.git/blob - media-sound/mpc/mpc-0.16.ebuild
Update moo2-data ebuild for gog updates.
[gentoo-draconx.git] / media-sound / mpc / mpc-0.16.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/media-sound/mpc/mpc-0.16.ebuild,v 1.1 2009/05/25 20:22:16 angelos Exp $
4
5 EAPI=2
6 inherit eutils bash-completion
7
8 DESCRIPTION="A commandline client for Music Player Daemon (media-sound/mpd)"
9 HOMEPAGE="http://www.musicpd.org"
10 SRC_URI="mirror://sourceforge/musicpd/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
15 IUSE="iconv"
16
17 RDEPEND="iconv? ( virtual/libiconv )"
18 DEPEND="${RDEPEND}"
19
20 src_unpack() {
21         unpack ${A};
22
23         cd "${S}"
24         epatch ${FILESDIR}/${P}-playid.patch
25 }
26
27 src_configure() {
28         econf --disable-dependency-tracking \
29                 $(use_enable iconv)
30 }
31
32 src_install() {
33         emake install DESTDIR="${D}" || die "emake install failed"
34         dodoc AUTHORS NEWS README
35         dodoc doc/mpd-m3u-handler.sh doc/mppledit doc/mpd-pls-handler.sh
36         rm -rf "${D}"/usr/share/doc/${PN}
37         rmdir "${D}"/usr/share/${PN}
38
39         dobashcompletion doc/mpc-bashrc
40 }